The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

/scrtips/cpup error

Discussion in 'General Discussion' started by big, Nov 17, 2003.

  1. big

    big Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    224
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    root@server [~]# /scripts/upcp
    PHP version file is up to date
    Doing a manual update...
    Cpanel updates are coming from layer2.cpanel.net
    rpm database is corrupt. rpm claims glibc is not installed. hackcheck cannot continue at /scripts/hackcheck line 89.
    SENT ipcheck email
    send to CONTACTEMAIL (3) [2]
    Checking /dev/hda....OK
    x - creating lock directory
    x - SKIPPING /usr/local/lib/php.ini (file already exists)
    Using Mysql4
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    proftpd is not up to date (Wed Dec 31 19:00:00 1969)
    Retrieving http://updates.cpanel.net/pub/sysup//9/proftpd/proftpd-1.2.8tlsp-6_linuxprivs.i386.rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    bandmin is not up to date (Wed Dec 31 19:00:00 1969)
    Retrieving http://updates.cpanel.net/pub/sysup//9/bandmin/bandmin-1.6-7.noarch.rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm

    Broadcast message from root (Mon Nov 17 19:32:06 2003):

    cPanel Layer 2 Install Complete
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    chkservd is not up to date (Wed Dec 31 19:00:00 1969)
    Retrieving http://updates.cpanel.net/pub/sysup//9/chkservd/chkservd-6.1-0.noarch.rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index using db3 - Resource temporarily unavailable (11)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages database in /var/lib/rpm


    how to rebuild the cprrupted rpm database?
     
    #1 big, Nov 17, 2003
    Last edited: Nov 17, 2003
  2. solan

    solan Active Member

    Joined:
    Apr 11, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Rebuild the RPM database

    # rpm --rebuilddb

    then

    # rpm --initdb

    you might want to run these two commands twice ;)

    then run your /scripts/upcp

    also if your trying to fix your cpanel and trying to use the edge version, its not working right now from what I've seen ... to fix this also change

    edit /etc/cpupdate.config

    -----------mine-------------
    CPANEL=stable
    RPMUP=stable
    SYSUP=stable

    ----------end---------------

    then run the /scripts/upcp command .. this will revert your cpanel version back to 8.5.3_STABLE_3 --- I've had to do this to a few box's
     
  3. big

    big Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    224
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    but i dont have /etc/upcpdate.config !
     
  4. solan

    solan Active Member

    Joined:
    Apr 11, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    then just create one with this info in it only


    CPANEL=stable
    RPMUP=stable
    SYSUP=stable


    then run your /scripts/upcp
     
  5. solan

    solan Active Member

    Joined:
    Apr 11, 2003
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    and its /etc/cpupdate.config

    not /etc/upcpdate.config ;) hehehe

    Just trying to help
     
  6. big

    big Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    224
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    found it its /etc/cpupdate.conf

    thanks :)
     
  7. unter

    unter Member

    Joined:
    Oct 27, 2003
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Easy fix;

    export LD_ASSUME_KERNEL=2.2.5
    rpm --rebuilddb
    rpm --initdb
    /scripts/upcp

    The problem is it needs the
    export LD_ASSUME_KERNEL=2.2.5
    to not exit with 980892342 errors.
     
  8. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    A little late maybe but for those who get the problem nowdays here's my fix:

    delete all _db.xxx files in /var/lib/rpm
    then rebuild the RPM database like this:

    rpm --rebuilddb
    rpm --initdb


    Took care of all the rpm errors I got when trying to run upcp:

    pmdb: Program version 4.2 doesn't match environment version
    error: db4 error(22) from dbenv->open: Invalid argument
    error: cannot open Packages index using db3 - Invalid argument (22)
    error: cannot open Packages database in /var/lib/rpm
    rpmdb: Program version 4.2 doesn't match environment version
    error: db4 error(22) from dbenv->open: Invalid argument
    error: cannot open Packages database in /var/lib/rpm
     
  9. steel rat

    steel rat Active Member

    Joined:
    Dec 27, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    When I try the rpm --rebuild command I get the following response:

    rpmdb: unable to join the environment
    error: db4 error(11) from dbenv->open: Resource temporarily unavailable
    error: cannot open Packages index

    Any ideas?
     
  10. steel rat

    steel rat Active Member

    Joined:
    Dec 27, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Helloooo? Still having the problem...
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    export LD_ASSUME_KERNEL=2.4.1

    then update your rpm rpms from rpm.org
     
  12. steel rat

    steel rat Active Member

    Joined:
    Dec 27, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    By updating rpms I assume you mean the rebuilddb command as outlined above?
     
  13. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    No he means your actual rpm, rpm. Confusing i know. The package rpm itself is what he's suggesting you update. Assuming you are running Redhat 9 ( naughty naughty, its EOL! ), follow the instructions here:
    http://www.fedora.us/wiki/LegacyRPMUpgrade
     
  14. steel rat

    steel rat Active Member

    Joined:
    Dec 27, 2004
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Naughty naughty? Come on that's not helpful. So the alternative is to start paying for it. might as well go with MS. And that page link doesn't load either.

    Can someone just spell out what I need to do instead of hinting?

    FYI, I did what Nick mentioned with the export command, then did the rebuilddb and initdb, and upcp ran successfully manually. But the cron that runs nightly is still having the same problem.
     

Share This Page