The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Secondary DNS without cpanel

Discussion in 'Bind / DNS / Nameserver Issues' started by bizzness, Apr 19, 2004.

  1. bizzness

    bizzness Member

    Joined:
    Feb 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Is it possible to have a secondary DNS and sync with master without installing Cpanel...

    Thanks
     
  2. perlchild

    perlchild Well-Known Member

    Joined:
    Sep 1, 2002
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    That is the point of cpanel's dns-only installer, or did you mean secondary->on a machine which already has a control panel??
     
  3. bizzness

    bizzness Member

    Joined:
    Feb 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    where can I find cpanel's dns-only installer ?
    How much does it cost ?
     
  4. bizzness

    bizzness Member

    Joined:
    Feb 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I have found the download file and the answer of my second question, is there a documentation in order to sync the second DNS with my primary DNS.

    Best regards
     
  5. bizzness

    bizzness Member

    Joined:
    Feb 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I have found the documentation and try to do this :
    http://www.cpanel.net/docs/dnsclustering-quickstart/

    But I've got this error :
    There was an error while processing your request: Cpanel::Accounting returned [HTTP/1.0 900 NET OR SSL ERROR ./cgi/trustclustermaster.cgi 19044: open_tcp_connection: failed `xxx.xx.xxx.8', 2087 (Connection refused) ]

    I have tried to run stunnel with script and that doesn't work...

    Firewall is down as well

    What I have to do?



    Thanks
     
  6. bizzness

    bizzness Member

    Joined:
    Feb 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
  7. bizzness

    bizzness Member

    Joined:
    Feb 25, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    No Named daemon

    When I look at named service with a ps -efda there is no service on cpanel dns-only machines

    Is it normal ?

    I haven'recieve any answer for my ssl questions, can you explain me how to create the stunnel connection or enable 2087 connection on a dns-only machine ?
     
  8. alex042

    alex042 Well-Known Member

    Joined:
    Sep 13, 2003
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Anyone know how to setup a Helm windows server as NS2? Currently, it seems that it kind of works, but I have to manually add domains to NS2 for it to update records for the domain from NS1 which is running cpanel.
     
  9. ckacerguis

    ckacerguis Member

    Joined:
    Aug 28, 2003
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    FYI - I had the same problem, here is what I did.

    1. Stop the cpservd process
    2. rm -Rf /usr/local/cpanel
    3. rm -Rf /root/installd/

    Then reinstall cpanel-dnsonly

    Worked like a champ.
     
  10. Jeff-C

    Jeff-C Well-Known Member

    Joined:
    Mar 16, 2004
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    16
    Thank You!

    rm -Rf /usr/local/cpanel
    rm -Rf /path-to-install-files/installd/

    works like a champ! Thank you very much!
     
  11. daniele81

    daniele81 Member

    Joined:
    Aug 27, 2003
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    fixing stunnel on DNS-ONLY

    In dns-only version, if stunnel don't work (port 2083 and 2087 are disabled) you can try this:

    # /usr/sbin/stunnel /usr/local/cpanel/etc/stunnel/default/stunnel.conf

    Work fine, for me (i'm on Fedora 2).
    If you want, you can put this command on script /etc/init.d/dnsonly for execute the command at boot.

    I apologize for my english.
    Best regards,
    Daniele.
     
Loading...

Share This Page