Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Secondary/Slave DNS server not getting new zones

Discussion in 'Bind/DNS/Nameserver' started by tlovrec, Apr 11, 2008.

  1. tlovrec

    tlovrec Member

    Joined:
    Apr 11, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    51
    Hello,

    I have a little problem with my Slave DNS server.
    When I add a zone in cPanel it gets inserted into /etc/named.conf, and creates a zone file as it should on the Primary server. But the Secondary server doesn't get that zone, not in /etc/named.conf nor does it create zone files.
    If I manualy add the zone in /etc/named.conf on the Secondary server and create the zone files then it updates on changes as it should.
    Now this works for me just good I have no problems adding manualy to the secondary, but my client wont like it this way.
    Can anyone point me to the right direction of what I must do?
    Thank you!

    Regards,
    Thomas
     
  2. tlovrec

    tlovrec Member

    Joined:
    Apr 11, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    51
    Is this a cPanel problem or should I be looking in DNS configurations?
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,216
    Likes Received:
    10
    Trophy Points:
    313
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Primary/Slave DNS server configurations are no longer recommended, DNS Clustering is preferred.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice