Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED section missed on dns lookup

Discussion in 'E-mail Discussion' started by hookie, Jan 29, 2018.

  1. hookie

    hookie Member

    Joined:
    May 12, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens, Greece
    cPanel Access Level:
    Root Administrator
    Hi all,
    I'm unable to send msgs to a domain (domain.cn) from a server...
    When dig its mailserver on port 25, I get all sections fine but "ADDITIONAL SECTION"
    (OPT PSEUDOSECTION / QUESTION SECTION / ANSWER SECTION / AUTHORITY SECTION)

    The following section might solve my problem:

    ;; ADDITIONAL SECTION:
    ce1.dns.com. 165331 IN A 121.12.104.123
    ce1.dns.com. 165331 IN A 183.2.194.187
    ce1.dns.com. 165331 IN A 218.66.171.187
    ce1.dns.com. 165331 IN A 218.98.111.187
    ce2.dns.com. 165331 IN A 183.2.194.188
    ce2.dns.com. 165331 IN A 218.66.171.188
    ce2.dns.com. 165331 IN A 218.98.111.188
    ce2.dns.com. 165331 IN A 121.12.104.124

    How can I add it to server?
    Thank you in advance!
     
    #1 hookie, Jan 29, 2018
    Last edited by a moderator: Jan 31, 2018
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,699
    Likes Received:
    1,790
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you clarify what you see in /var/log/exim_mainlog when attempting to send a message to that domain name?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. hookie

    hookie Member

    Joined:
    May 12, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens, Greece
    cPanel Access Level:
    Root Administrator
    Hello

    Here is what I get in exim_mainlog:

    2018-02-02 14:15:55 1ehaG3-0004Y3-4Z <= user@senderdomain.com H=([192.168.1.39]) [91.140.105.74]:55880 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_plain:user@senderdomain.com S=5047 id=29403f83-18cd-6d64-ac60-651e03ceb0d3@senderdomain.com T="test message" for recipient@domain.cn

    2018-02-02 14:30:38 1ehaG3-0004Y3-4Z SMTP connection outbound 1517225438 1eg7e2-0002Wi-10 senderdomain.com recipient@domain.cn

    2018-02-02 14:42:33 1ehaG3-0004Y3-4Z == recipient@domain.cn R=dkim_lookuphost T=dkim_remote_smtp defer (110): Connection timed out

    2018-02-02 14:48:33 1ehaG3-0004Y3-4Z == recipient@domain.cn R=dkim_lookuphost defer (-1): host lookup did not complete

    Then the queue keeps sending "Connection timed out" for the next days...

    Thank you so much for your help!
     
    #3 hookie, Feb 2, 2018
    Last edited: Feb 2, 2018
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,699
    Likes Received:
    1,790
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    It looks like a firewall rule (or a router rule implemented by your data center) on the cPanel server, or a firewall rule on the remote mail server is preventing the cPanel server from connecting to the remote mail server hosting the email for that domain name. You can verify this by running a command such as:

    Code:
    telnet domain.tld 25
    Replace "domain.tld" with the actual domain name you are attempting to send the email to.

    The normal output should resemble this:

    Code:
    # telnet domain.tld 25
    Trying 1.2.3.4...
    Connected to domain.tld.
    Escape character is '^]'.
    220-host.www.domain.tld ESMTP Exim 4.89_1 #1 Fri, 02 Feb 2018 10:52:40 -0600
    220-We do not authorize the use of this system to transport unsolicited,
    220 and/or bulk e-mail.
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    hookie likes this.
  5. GrupoDSP.com

    GrupoDSP.com Registered

    Joined:
    Feb 2, 2018
    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    78
    Location:
    Peru
    cPanel Access Level:
    Root Administrator
    Check the configuration of your firewall, many times similar cases happen because inside our Firewall ConfigServer Security & Firewall> the IP of the external server was being blocked,

    Also check the configuration of your firewall> Configuration> cc_deny, verify that you are not blocking an entire country and that the IP may be in that range of IPs,

    Another alternative is to place the IP in the white list of your firewall.
     
    hookie likes this.
  6. hookie

    hookie Member

    Joined:
    May 12, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens, Greece
    cPanel Access Level:
    Root Administrator
    Yes, it was the Firewall!!! Thank you very much!
     
  7. hookie

    hookie Member

    Joined:
    May 12, 2014
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Athens, Greece
    cPanel Access Level:
    Root Administrator
    Exactly this!
    Forgot I've blocked that country in the past due to spam mails!!!
    Many thanks!!!!
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,699
    Likes Received:
    1,790
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm glad to see the issue is now solved. Thank you for sharing the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice