The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Secure Page (https) cannot be open

Discussion in 'General Discussion' started by MakassarNET, Mar 31, 2006.

  1. MakassarNET

    MakassarNET Well-Known Member

    Joined:
    Dec 6, 2004
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    I have install a SSL Certificate for my billing area, but the secure site cannot be open. If I'm trying to open the site with http it's open but when I'm trying it with https, cannot be open. But I have install the SSL Cerificate correctly. But what make me confused, when I go to "Show IP Address Usage", the IP for the secure site is still using public IP instead of Dedicated IP that I have choosen during the SSL installation. I also check the httpd.conf, I found 2 section for the domain name which I'm install the SSL for. One is the ussual configuration (<VirtualHost 123.123.123.1>) and the other one with the 443 port (<VirtualHost 123.123.123.2:443>). The dedicated IP choosen for the SSL let say 123.123.123.2 and the configuration in httpd.conf for the SSL is already correct, but the secure site cannot be open.

    My question is, do I also need to change the IP for the non SSL configuration in the httpd.conf? Or is there anyway to fix this issue if I don't need to change those IP to dedicated IP?


    Thank,
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    I guess both IP's to be the same. ie before installing the SSL certificate, you have to assign that domain a dedicated IP.
     
  3. MakassarNET

    MakassarNET Well-Known Member

    Joined:
    Dec 6, 2004
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    I have change the httpd.conf to make the IP point to the same IP. But still, the secure site cannot be open and in the "Show IP Address Usage", the dedicated IP that I have been using or pointing for the SSL, is still empty. It should be list there the domain name right? But this one not. The secure site domain is still list in the public sharing IP.

    Help me please!


    Thanks,
     
  4. JamesCTotalWeb

    JamesCTotalWeb Well-Known Member

    Joined:
    Mar 20, 2005
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    In WHM find the link Change Site's IP Address locate the domain you are reffering to and point it to the right IP .. this should change the DNS settings IP and everything should work out.

    Just changeing the http.conf will not do the trick. ;)
     
  5. MakassarNET

    MakassarNET Well-Known Member

    Joined:
    Dec 6, 2004
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Well, if I do that, it will change the entire site IP. Cause the secure site is in subdomain not the main domain. Any other suggestion?


    Kind Regards,
     
Loading...

Share This Page