The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Security Advisory - RHSA-2003:403-07

Discussion in 'Security' started by Go2reg, Dec 17, 2003.

  1. Go2reg

    Go2reg Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    ------------------------------------------------------------------------------
    Summary:
    Updated lftp packages fix security vulnerability

    Updated lftp packages are now available that fix a buffer overflow security vulnerability.

    Description:
    lftp is a command-line file transfer program supporting FTP and HTTP protocols.

    Ulf Härnhammar discovered a buffer overflow bug in versions of lftp up to and including 2.6.9. An attacker could create a carefully crafted directory on a website such that, if a user connects to that directory using the lftp client and subsequently issues a 'ls' or 'rels' command, the attacker could execute arbitrary code on the users machine. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0963 to this issue.

    Users of lftp are advised to upgrade to these erratum packages, which contain a backported security patch and are not vulnerable to this issue.
     
  2. Go2reg

    Go2reg Active Member

    Joined:
    Apr 30, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Security Advisory - RHSA-2003:320-09
    ------------------------------------------------------------------------------
    Summary:
    Updated httpd packages fix Apache security vulnerabilities

    Updated httpd packages that fix two minor security issues in the Apache Web server are now available for Red Hat Linux 8.0 and 9.

    Description:
    The Apache HTTP Server is a powerful, full-featured, efficient, and freely-available Web server.

    An issue in the handling of regular expressions from configuration files was discovered in releases of the Apache HTTP Server version 2.0 prior to 2.0.48. To exploit this issue an attacker would need to have the ability to write to Apache configuration files such as .htaccess or httpd.conf. A carefully-crafted configuration file can cause an exploitable buffer overflow and would allow the attacker to execute arbitrary code in the context of the server (in default configurations as the 'apache' user). The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0542 to this issue.

    A bug in the CGI daemon-based "mod_cgid" module was discovered that can result in CGI script output being sent to the wrong client. This issue only affects Red Hat Linux 9, and only when the server is configured to use the "worker" MPM. The default configuration uses the "mod_cgi" module for CGI and is not affected by this issue. The Common Vulnerabilities and Exposures project (cve.mitre.org) has assigned the name CAN-2003-0789 to this issue.

    Users of the Apache HTTP Server should upgrade to these erratum packages, which contain backported patches correcting these issues, and are applied to Apache version 2.0.40.


    This is from Red Hat. <--------
     
Loading...

Share This Page