The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SecurityAdvisor and EasyApache 4 suexec link

Discussion in 'EasyApache' started by Karl, Sep 9, 2016.

  1. Karl

    Karl Well-Known Member
    PartnerNOC

    Joined:
    Aug 10, 2001
    Messages:
    84
    Likes Received:
    1
    Trophy Points:
    8
    Jacob - The cPanel Security Advisor in WHM links you through to the suEXEC page, even when running EA4 if it thinks you're not using suEXEC. We're running mod_lsapi and see this.
     
  2. Takumi80

    Takumi80 Member

    Joined:
    Nov 7, 2015
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Milan
    cPanel Access Level:
    Root Administrator
    Hello,

    after upgrade of EasyApache 4 i have provisions this template "CloudLinux + All PHP Options + OpCache + mod_lsapi" but in the security advisor there is an error:

    suEXEC is disabled.Enable suEXEC on the “Configure PHP and suEXEC” page.

    but in multi php management there is only suphp/none/cgi
    there isn't suExec

    where i wrong?
    thanks
     
    #2 Takumi80, Sep 20, 2016
    Last edited by a moderator: Sep 21, 2016
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello @Karl,

    I've opened internal case CPANEL-8844 to address this issue, and I'll update this thread with more information about this case as it becomes available.

    Thank you.
     
  4. Bazinga

    Bazinga Active Member

    Joined:
    Aug 23, 2016
    Messages:
    26
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    Ukraine
    cPanel Access Level:
    Website Owner
    I believe that is a bug in cPanel's security advisor, someone from cpanel should reply. No actions needed by CL.
     
  5. Bansiji

    Bansiji Registered

    Joined:
    Sep 27, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Bholam
    cPanel Access Level:
    Root Administrator
    Hello,

    I have a dedicated server with
    CLOUDLINUX 6.8 x86_64 standard WHM 58.0 (build 30)

    cPanel Security Advisor gives an error
    suEXEC is disabled.
    Enable suEXEC on the “Configure PHP and suEXEC” page

    When I go to “Configure PHP and suEXEC” page it shows
    The EasyApache4 Technology Preview needs to be configured via command-line tools. The WHM user interface does not currently support this Technology Preview

    How to enable "suEXEC" ?

    Please help

    Thanks
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello @Bansiji,

    I've moved your post into this thread. Note that in addition to the earlier response, CPANEL-7731 addresses an additional issue with CloudLinux and Security Advisor:

    Case CPANEL-7731: The cPanel EA 4 suexec binary uses capabilities, but CloudLinux's uses the setuid bit. Detect both cases properly.

    The resolution is included with cPanel version 60, which is not yet released. Information on the build/release process at:

    Product Versions and the Release Process - cPanel Knowledge Base - cPanel Documentation

    Thank you.
     
Loading...

Share This Page