The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Segfaults all over the place!

Discussion in 'General Discussion' started by ozzi4648, Mar 2, 2003.

  1. ozzi4648

    ozzi4648 Guest

    Anyone see a few of these?

    [Sun Mar 2 13:39:54 2003] [notice] child pid 23106 exit signal Segmentation fault (11) Cpanel 6.0.0-S97
     
    #1 ozzi4648, Mar 2, 2003
    Last edited by a moderator: Mar 2, 2003
  2. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I ran the latest buildapache on all my servers, now /etc/httpd/error_log is reporting a seg fault every second, on all boxes.
     
  3. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I ran buildapache on two servers this morning and am not seeing those errors in the error log.
     
  4. Shiekron2

    Shiekron2 Active Member

    Joined:
    Apr 17, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Same here:

    Code:
    [Tue Mar  4 01:20:06 2003] [notice] child pid 14087 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:06 2003] [notice] child pid 14082 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:06 2003] [notice] child pid 13874 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:06 2003] [notice] child pid 13422 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:07 2003] [notice] child pid 14092 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:07 2003] [notice] child pid 14089 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:07 2003] [notice] child pid 14088 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:07 2003] [notice] child pid 13764 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:08 2003] [notice] child pid 14095 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:08 2003] [notice] child pid 14094 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:08 2003] [notice] child pid 14093 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:09 2003] [notice] child pid 14107 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:09 2003] [notice] child pid 14098 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:09 2003] [notice] child pid 14097 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:09 2003] [notice] child pid 13518 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:10 2003] [notice] child pid 14111 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:10 2003] [notice] child pid 14110 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:10 2003] [notice] child pid 14086 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:10 2003] [notice] child pid 13924 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:10 2003] [notice] child pid 13766 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:11 2003] [notice] child pid 14120 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:11 2003] [notice] child pid 14118 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:11 2003] [notice] child pid 14117 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:11 2003] [notice] child pid 14116 exit signal Segmentation fault (11)
    [Tue Mar  4 01:20:11 2003] [notice] child pid 14114 exit signal Segmentation fault (11)
    
    Seg fault galore.
     
  5. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Nick ......
    Help!
     
  6. ozzi4648

    ozzi4648 Guest

    Wow i have no seg faults compared to you. Are those all in one row or just copied from your logs from all over? I dont think i will install the latest buildapache.sea. It seems to be causing more problems then not.
     
  7. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    I tried recompiling Apache again early morning with no modules and downgrading PHP, still no luck. Apache is crapping out when trying to server PHP pages that utilize open sockets.

    [Tue Mar 4 08:30:22 2003] [notice] child pid 30662 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:23 2003] [notice] child pid 30663 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:24 2003] [notice] child pid 30661 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:24 2003] [notice] child pid 30660 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:25 2003] [notice] child pid 30666 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:25 2003] [notice] child pid 30646 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:26 2003] [notice] child pid 30668 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:26 2003] [notice] child pid 30640 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:27 2003] [notice] child pid 30669 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:28 2003] [notice] child pid 30672 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:29 2003] [notice] child pid 30674 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:30 2003] [notice] child pid 30679 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:30 2003] [notice] child pid 30678 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:31 2003] [notice] child pid 30683 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:31 2003] [notice] child pid 30682 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:31 2003] [notice] child pid 30680 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:31 2003] [notice] child pid 30673 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:31 2003] [notice] child pid 30634 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:32 2003] [notice] child pid 30671 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:35 2003] [notice] child pid 30700 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:35 2003] [notice] child pid 30699 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:35 2003] [notice] child pid 30692 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:38 2003] [notice] child pid 30702 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:38 2003] [notice] child pid 30684 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:40 2003] [notice] child pid 30704 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:42 2003] [notice] child pid 30712 exit signal Segmentation fault (11)
    [Tue Mar 4 08:30:42 2003] [notice] child pid 30703 exit signal Segmentation fault (11)
     
  8. Shiekron2

    Shiekron2 Active Member

    Joined:
    Apr 17, 2002
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Run the following command in your boxes:

    Code:
    ulimit -n 16384;/scripts/restartsrv httpd
    
    Thank you
     
  9. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Segfaults started to reappear for me
     
  10. kcdworks

    kcdworks Well-Known Member

    Joined:
    Jul 28, 2002
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    Did you run the command

    ulimit -n 16384;/scripts/restartsrv httpd

    like he posted, and they are reappearing after that?
     
  11. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Yeah, also added ulimit -n 16384 to /etc/rc.d/init.d/httpd.

    Everything was running fine for about 8-10 hours, then Segfaults started popping up again like before.

    The weird thing is, during a segfault, pages that have:

    <?
    include("http://www.domain.com/include.html")
    ?>

    Don't work, but pages that have includes like:

    <?
    include("include.html")
    ?>

    Work just fine

    After an httpd restart, both includes work without problem
     
  12. Jontxu40

    Jontxu40 Well-Known Member

    Joined:
    Dec 9, 2002
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Same too

    Hi:

    I have the same problem after rebuild apache with buildapache.sea (Sat Mar 1 18:23:24 2003)

    to much lines at error_log:

    child pid 14087 exit signal Segmentation fault (11)

    And at that moment, some PHP functions begin to fail

    By example , the php function fopen() .

    Any ideas ?
     
  13. techid

    techid Member

    Joined:
    Aug 5, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    I am also having this issue..

    I tried raising the ulimit.
    I tried reverting to an older PHP version.
    I tried compiling just the bare minimal to make things work.

    Besides the Segmentation Faults, I receive this when a user tries to call something via PHP

    [Wed Mar 5 13:40:30 2003] [notice] SIGUSR1 received. Doing graceful restart
    [Wed Mar 5 13:40:30 2003] [notice] Apache/1.3.27 (Unix) DAV/1.0.3 mod_bwprotect/0.2 mod_log_bytes/1.0 mod_bwlimited/1.0 PHP/4.3.1 FrontPage/5.0.2.2510 mod_ssl/2.8.12 OpenSSL/0.9.6b configured -- resuming normal operations
    [Wed Mar 5 13:40:30 2003] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
    [Wed Mar 5 13:40:30 2003] [notice] Accept mutex: sysvsem (Default: sysvsem)
     
  14. kcdworks

    kcdworks Well-Known Member

    Joined:
    Jul 28, 2002
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    Download and run the newest buildapache ... there was a typo in the previous version.
     
  15. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Woohooo! (Wed Mar 5 16:20:48 2003)!
     
  16. kcdworks

    kcdworks Well-Known Member

    Joined:
    Jul 28, 2002
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    Thank Shaun for that info ... he posted it in another thread and I just updated this one ;)
     
  17. techid

    techid Member

    Joined:
    Aug 5, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    I ran the latest buildapache.sea (Wed Mar 5 16:35:16 2003) and I have no luck... I am still running into the same problems.

    Has anybody else ran this? What is your feedback?
     
  18. norm

    norm Well-Known Member

    Joined:
    Apr 23, 2002
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Same here, Segmentation faults started appearing after a couple hours of usage.

    FYI: The proper ulimit was placed at the top of httpd
     
  19. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    What version of php are you using?

    Did you try downgrading to 4.2.3?

    What php modules have you compiled in?

    Please post as much information as possible so we can track down where the bug is. Right now it appears to be a problem with 4.3.1 as every machine I've seen with the problem has 4.3.1.
     
  20. techid

    techid Member

    Joined:
    Aug 5, 2002
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    I have compiled with both PHP 4.2.3 and PHP 4.3.1 both resulting with the same outcome. In a second I will gather a list of modules I am compiling with.
     
Loading...

Share This Page