Segmentation Fault 11 for one account

dbrookeJP

Active Member
Aug 24, 2016
28
1
3
Wisconsin
cPanel Access Level
Root Administrator
WHM / cPanel 68.0.19
PHP 7.0.26 via MultiPHP
Apache/2.4.33

Hello, A few days ago, a newer account that has been working just fine for the last several months is all the suddon doing a (delayed) seg fault after a period of time.

Apache Restart (from WHM) fixes it only temporarily. It could work for 6 hours without problems... or 6 minutes.

Specifically, this is a domain that forces HTTPS. When the issue is happening, I can call the domain with a browser, and it looks like there is a loop that is happening trying to establish a TLS handshake. Finally, the browser quits.

For logs, so far, I have only found this (in /var/log/apache2/error_log):
Code:
[Fri Apr 06 10:06:04.638233 2018] [rewrite:warn] [pid 25395:tid 140330630309632] AH00664: RewriteOptions: MaxRedirects option has been removed in favor of the global LimitInternalRecursion directive and will be ignored.
[Fri Apr 06 10:06:04.934400 2018] [rewrite:warn] [pid 25395:tid 140330630309632] AH00664: RewriteOptions: MaxRedirects option has been removed in favor of the global LimitInternalRecursion directive and will be ignored.
[Fri Apr 06 10:06:05.907777 2018] [rewrite:warn] [pid 25455:tid 140330619819776] AH00664: RewriteOptions: MaxRedirects option has been removed in favor of the global LimitInternalRecursion directive and will be ignored.
[Fri Apr 06 10:06:08.206393 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 25395 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:08.206441 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 25455 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:08.206459 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 25720 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:09.208109 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 25396 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:09.211808 2018] [rewrite:warn] [pid 26283:tid 140330777167616] AH00664: RewriteOptions: MaxRedirects option has been removed in favor of the global LimitInternalRecursion directive and will be ignored.
[Fri Apr 06 10:06:10.209785 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 26283 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:11.211408 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 26328 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:12.213037 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 26357 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:13.214628 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 26386 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:13.216713 2018] [rewrite:warn] [pid 26422:tid 140330766677760] AH00664: RewriteOptions: MaxRedirects option has been removed in favor of the global LimitInternalRecursion directive and will be ignored.
[Fri Apr 06 10:06:13.216713 2018] [rewrite:warn] [pid 26422:tid 140330777167616] AH00664: RewriteOptions: MaxRedirects option has been removed in favor of the global LimitInternalRecursion directive and will be ignored.
[Fri Apr 06 10:06:14.216287 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 26422 exit signal Segmentation fault (11)
[Fri Apr 06 10:06:15.217895 2018] [core:notice] [pid 23179:tid 140331110463616] AH00052: child pid 26453 exit signal Segmentation fault (11)
My original thought is that it had something to do with AutoSSL.. because this site uses an actual (comodo) Cert and I have turned off autoSSL for this domain. So, I turned off AutoSSL entirely, and the problem still happens.

Any ideas on how to troubleshoot this would be appreciated.

TIA,
Donovan
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
Hi @dbrookeJP

To clarify are you reaching the segfault only on the https version of the site? I ask this only because we have an internal issue EA-7366 in which updates to the apr-util a couple of nights ago did not include dependencies if rpmup up=no in /etc/cpupdate.conf, in turn, this caused us to need to open a new internal case EA-7380 due to the mysql-1.so in the apr-util links to openssl were not working properly.

This was fixed last night and I would suggest updating to retrieve the patch. Please let us know if updating does not resolve this.

Thank you,
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,266
313
Houston
Hi @dbrookeJP

Yes, please update and let us know if you continue to experience the issue. If you do please open a ticket using the link in my signature so that we can take a closer look.

Thank you!