Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Segmentation Fault Error on /scripts/upcp

Discussion in 'General Discussion' started by DigitalSurgeon, Oct 9, 2005.

  1. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    I am having the problem that I can't access the cpanel using www.domain.com/cpanel but can access through www.domain.com:2082 and also having problem in accessing WHM.I tried to upgrade cpanel using /scripts/upcp but it just prints the single Segmentation Fault.

    Any thoughts how to proceed ????
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    I have checked and all entries in the httpd.conf are same :( Still nothing happened Any new thing to check to resolve this
     
  4. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    166
    What operating system??
    Are you using grsecurity??
    Are you using libsafe??

    What version perl are you using?? (perl -v)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    I am even getting Segmentation Fault on perl -v :(
     
  6. StevenC

    StevenC Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    252
    Likes Received:
    0
    Trophy Points:
    166
    Well that would be why cpanel is not working also. You could try to reinstall perl, but that is a cookie cutter fix. I have seen this for various reasons, bad hardware, grsecurity bad, alot of times i see this on COMPROMISED machines.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    Thanks alot ...Ok I'll try it to reinstall perl
     
  8. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    Do you get Segmentation Fault only on perl, or on any command you run? Did you check the log files for more errors?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. DigitalSurgeon

    DigitalSurgeon Well-Known Member

    Joined:
    Aug 13, 2005
    Messages:
    134
    Likes Received:
    0
    Trophy Points:
    166
    No, it gives Segmentation Fault on starting exim, upcp and also WHM is just showing blank page,Cpanel is working with domainname.com:2082 but not with domainname.com/cpanel.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice