The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Send Email Stopped Working

Discussion in 'E-mail Discussions' started by ladierainy, Feb 3, 2005.

  1. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I;ve done a few searches on this, nothing seems to match so far.

    All a sudden I am unable to send email, though I can receive it.

    I haven;t made any changes, just one day I can send the next few days I can't.

    I believe all emails are using POP3, not STMP.

    Please help! :(

    What should I check or do?

    Thanks!
     
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    have u checked if there are any firewall blocks on the server ?
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    from a windows command line:

    telnet mail.your_domain.tld 25

    do you get a hello from your box? if not ..bitch at your ISP, they just joined the list of isps that block 25 to outside world. Consider using port 26 and enable it on your server so exim will bind to more than one port. If that's not what you want start using your IPS smtp server.
     
  4. Dacsoft

    Dacsoft Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Melbourne, Florida
    I have 2 accounts that this just started happening. It isn't the firewall, because I have multiple accounts on this server. Webmail works fine, and everything is set the same on all the accounts.
     
  5. vibz

    vibz Member

    Joined:
    Jan 24, 2005
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Dude!!! The information that have given is very little.

    What is the error message that you get?
    Did you check your server logs?
    Try sending a mail and at the same time check "tail -f /var/log/exim_mainlog" and see what is happening.
    Also, check if you have SMTP authentication enabled in your email client.

    Vibz
     
  6. Dacsoft

    Dacsoft Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Melbourne, Florida
    I just had this happen with one of my accounts. The problem turned out to be that the File "shadow" should be user.mail, and is user.user for owner and group. The files are in:
    /home/usernamer/etc
    /home/username/etc/domaim.name/

    you have to check this is SSH. So if you can't do it ,ask your provider. If you have SSH, check the file permissions.
     
  7. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6

    All it says is:

    Error reading from network. Cause: connection closed by foreign host. (0)

    It's pretty a durn sparse error message. I use Eudora. It sent fine one day (and it's been sending fine for years) - and then this week - nada. I hadn't done a thing to my server - not sure why this would happen - haven't heard any compliant yet from my clients I'm hosting - so it's possible it's just all MY sites. I have around 20, and NONE of their emails will send. On either of my computers. I asked one client, that I've managed to reach so far, they said everything was fine on their end, so I'm still not sure if this is just me, or if it's server wide. I suspect that alone would tell me a lot.

    I did what you suggested - odd thing was MY email and the domain never even appeared in that log, even while I was watching it and trying to send the email several times.

    SMTP is enabled in all my email clients.

    Thanks for your time and suggestions!
     
  8. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6

    My server support folks said they flushed all my firewalls.

    I'd imagine that would mean it should be fine ... I think.

    Sorry I'm a total newbie, but trying to learn more.

    Thanks for your time and suggestion!
     
  9. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    i've never been good at the shell thing - I used the windows run command field, and it shut down the box too fast to allow me to see what it said. I might have done that wrong. *sigh*

    How would I enable port 26 on my server? (I will be doing a search for that to see if I can answer my own question - just asking in case I come up wih nada lol).

    Not sure *how* to use my ISP's smtp server. Any suggestions, or links you might know of that would tell me how to do that?

    Thanks so much for your time and suggestions!
     
  10. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6

    Can I access that via FTP? I saw the files there using my FTP, but didn't see anythign that said either user.user or user.mail

    I might be misunderstanding what you were tellig me though.

    Thanks much for your time and suggestions!
     
  11. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Ahhh called my ISP - seems sbcglobal is having a small issue with port 25. :(

    Says it will be a few days til they can get it fixed. So maybe adding port 26 is the solution that I need to do in the meantime.

    I'll do a search for that and see if there is a thread that addresses how to do that.

    Thanks everyone for all your time, patience and help with this blonde! LOL

    If anyone can find a thread or link that says how to add a por 26 to my server, please feel free to direct me, as sometimes I do seem to have trouble with my searches!

    Thank you all you all ROCK! :D
     
    #11 ladierainy, Feb 6, 2005
    Last edited: Feb 6, 2005
  12. Dacsoft

    Dacsoft Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Melbourne, Florida
    If you can see your sites, the firewall probably isn't the problem. Did you try any of the hints above? It really sounds like your ISP has started to block port 25. That port is required to send. Go to whm and activate port 26. Then change Eudora to port 26 and test again.

    Did you check the ownership of the shadow files mentioned above.
     
  13. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6

    Not sure how to activate port 26 using WHM, I'll poke around and see if I can find that.

    I have NO idea where the port assignment is in Eudora egads!

    I assume the ownership is the permissions? Not sure what you mean by the term ownership - I think I'm havign a brain fart! :(

    Can I check that with FTP? Or do I need to do that via shell?

    I tried to find it via shell, and couldn't see anything that said user.user, or user.mail like my reply post to you earlier detailed.

    Thanks for being SO patient!
     
  14. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    OOOoo! I *think* I found it!

    In service manager - exim on another port, and it had port 26 in it, so I checked that box, and clicked on save and then restarted my exim.

    Still no go, so I'm still missing something!
     
  15. Dacsoft

    Dacsoft Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Melbourne, Florida
    Great. So you have activate port 26 in WHM. Now try to find it in Eudora. I haven't used it in years so can't help. Once setup, you are ready for a test. Both the email client and the server must be using the same port.

    As mentioned above, you should be able to see if you can reach the email server using the telnet command (even if disabled on the server). Open a windows command window (go to Start -> Run and type cmd).

    type telnet mail.your_domain.tld 25
    and
    telnet mail.your_domain.tld 26

    If the port is available and not blocked, you should see some sort of hello message. Or probably a message saying relay is not allowed.


    If that doesn't work, check the owner and group of the shadow file. You can do it in some FTP programs, but ssh is normally easier.

    good luck
     
  16. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Found out how to change the ports for Eudora!

    But back to the shadow files:

    Owner and group are referring to permission settings, right?

    So like the shadow file and the shadow,v file should be set to 755 or something like that?

    I got it to send email on my main domain name, but on the other domains that share that same IP I'm getting this new error message:


    SSL Negotitation Failed: Certificate Error: Cert Chain not trusted. Try adding this ceritificate to your certificate database for SSL to succeed Certificate bad: Destination Hostname does not match hostname in certificate. Cause: (-6995)

    Egads! something new for me to search on!
     
  17. ladierainy

    ladierainy Well-Known Member

    Joined:
    Dec 1, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Aha!

    Found it!

    Had to change my SSL to Never.

    Sent JUST fine!

    Thanks everyone for guiding me through this you all are wonderful!!

    ~Muah!~
     
Loading...

Share This Page