The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Send mail from account’s dedicated IP - "Received by" in email body

Discussion in 'E-mail Discussions' started by Lor, Jun 26, 2014.

  1. Lor

    Lor Well-Known Member

    Apr 29, 2005
    Likes Received:
    Trophy Points:
    I setup exim configuration using WHM to "Send mail from account’s dedicated IP", but in email body I still see:

    Received: from ([]:52713 helo=[])
    	[B][COLOR="#FF0000"]by with esmtpsa[/COLOR][/B] (TLSv1: DHE-RSA-CAMELLIA256-SHA:256)
    	(Exim 4.82)
    	(envelope-from <>)
    	id 1X0Cwj-0001zN-8J
    	for; Thu, 26 Jun 2014 10:54:49 -0600
    Message-ID: <>
    Date: Thu, 26 Jun 2014 10:54:56 -0600
    From: Sam <>
    User-Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:24.0) Gecko/20100101 Thunderbird/22.2.0
    MIME-Version: 1.0
    To: John <>
    How to remove the part: by with esmtpsa from email body?

    I tried edit 'exim.conf' by:,

    but it's not working.

    Also SPF record for still pointed to main server IP?

    Any advices, please?
    #1 Lor, Jun 26, 2014
    Last edited: Jun 26, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please see the following document:

    How to Change the Sending IP for Outbound Email in Exim

    It lists steps on how to utilize the "Reference /etc/mailhelo for outgoing SMTP HELO" option. Note that you won't be able to completely hide the hostname of the server if that's your goal.

    Thank you.

Share This Page