The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Sender address displayed in headers

Discussion in 'E-mail Discussions' started by postcd, May 26, 2016.

  1. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    624
    Likes Received:
    6
    Trophy Points:
    18
    Hello,

    from my Gmail account im sending an email via my WHM server SMTP server, email is delivered. Also POP3 works OK, BUT in email headers i see as a Sender to be my gmail account.

    So this can either be
    1) a bug in GMail (unlikely, another Google Expert from productforums.google.com veriffied my Gmail configuraton is correct and he tried same config only his Hotmail SMTP and his gmail email was not exposed/revealed to the recipient)
    2) my WHM SMTP server (Exim in my case) is configured to somehow reveal/use real email sender (my gmail mailbox) and pass it in the email headers.

    My aim is to prevent it so my real email address/sender (gmail) is not revealed in the email headers that recipient can see. At same time i would like this to apply on my email address but other cpanel users continue be excluded (their real sender address be shown in headers as i assume this is some kind of abuse/antispam protection)

    Thank You
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Is it showing the specific Gmail address, or is it showing as sent from the specified email address, but mailed by Google? In your Gmail settings, have you configured the correct default email address under "Send mail as:"?

    Thank you.
     
  3. postcd

    postcd Well-Known Member

    Joined:
    Oct 22, 2010
    Messages:
    624
    Likes Received:
    6
    Trophy Points:
    18
    This was problem of the Gmail. I have to delete and again add account in Gmail's settings. Thank You for help!
     
Loading...

Share This Page