Sending Email through Dedicated IPs and HELO


Well-Known Member
Aug 21, 2005
We've enabled the cPanel option to send email through a client's dedicated IP if they have one. The feature works, but the HELO that is broadcast during an SMTP connection is still showing the server's hostname and main shared IP.

IIRC, we were able to get this to work properly back when we had to custom mod EXIM for this option by adding this:

primary_hostname =
smtp_active_hostname = ${lookup{$interface_address}lsearch{/etc/ip_hostnames}{$value}{$primary_hostname}}
smtp_banner = "${smtp_active_hostname} ESMTP Exim ${version_number}  \#${compile_number} ${tod_full} \n   We do not authorize the use of this system to transport unsolicited, \n   and/or bulk e-mail."
into the Advanced EXIM settings section for cPanel. I imagine with a little tweaking we could now use that code and mail_reverse_dns to do the same.

Was wondering if there is a cPanel option to achieve this rather than custom moding EXIM.

For completeness, the domain in question is correctly listed in /etc/mail_reverse_dns and /etc/mailips and they have correct RDNS resolution. Their DNS is also correctly pointing to their dedicated IP.


Active Member
Dec 7, 2004
Sending outgoing mail from client's dedicated IP

Just FYI: this will work for mail originating from the server, either from webmail or SMTP connection, but does not work for forwarders. Forwarded mail will still be sent out using the shared server IP, not the client's dedicated IP.

I wish there were a way that mail forwarders could send mail out using the shared server IP, but I've been told that's not possible.


Oct 20, 2007
I'm trying to get this same thing figured out. My email is being rejected by some servers as a 'forged helo' because it is sending out the dedicated IP and domain in the helo, but also the main/shaired IP, and therefore it is being seen as a 'forged HELO'.

In my case, I am using sendmail (vBulletin) and don't have phpsuexec enabled. That might be the issue in my case. I'm not sure.