Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Sending mail between two domains

Discussion in 'E-mail Discussion' started by gildas, Nov 30, 2018.

  1. gildas

    gildas Well-Known Member

    Joined:
    Mar 30, 2017
    Messages:
    55
    Likes Received:
    5
    Trophy Points:
    8
    Location:
    Paris
    cPanel Access Level:
    Root Administrator
    Hello,

    On the same body, two domains are named DomainJ and DomainS.
    Domain J domains point to Office 365 services.

    DomainS domain services to Office365 services, but an MX field is also created to the IP address of the CPANEL mail server.

    DomaineS domain, use the email service of CPANEL but also Office 365.

    The problem is that if you send an e-mail from the CPANEL DomainS domain to a box (create on Office365) Domain J, that's what you received by the default box CPANEL Domain J and not on the Office 365 box associated with this domain.

    Do you have a solution for sending an email from CPANEL and domain Domain sending well the mail to the address of DomainJ is create on Office365?
    A change must be made at the MX level of each domain? or a specific setting must be done on the WHM?

    Best Regards
     
  2. cPanelLauren

    cPanelLauren Forums Analyst II Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    6,248
    Likes Received:
    478
    Trophy Points:
    233
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @gildas


    I don't believe I'm understanding the question 100%

    These sound like DomainS may be doing a split delivery? But the issue doesn't sound like it's with DomainS but rather DomainS sending to DomainJ am I correct?

    This is the part I'm having trouble understanding, it sounds like you're sending from DomainS -> DomainJ and it's not being sent to Office365 but rather being sent locally. If that's correct can you make sure that DomainJ is in
    Code:
    /etc/remotedomains
    and that it is not present in
    Code:
    /etc/localdomains
    as it sounds like DomainJ doesn't get any of its mail on the server it shouldn't be present in localdomains.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice