Chriz1977

Well-Known Member
Sep 18, 2006
191
0
166
Hi

My clients are getting thhis message when trying to send mail via Outlook :

Task 'mail.real-force.org - Sending' reported error (0x800CCC65) : 'Your outgoing (SMTP) e-mail server has reported an internal error. If you continue to receive this message, contact your server administrator or Internet service provider (ISP). The server responded: 503 valid RCPT command must precede DATA'
Ive tried rebooting the server, etc but it wont go away. Ive had it before and after a while it goes away but I need a fix for my clients now. Can anyone help please?

Cheerz
Chris
 

Chriz1977

Well-Known Member
Sep 18, 2006
191
0
166
I have found a lot of references to this problem and advice on how to fix it :


If using MS Outlook, please try the following:

1) Open outlook
2) Go to Tools/Email Accounts
3) Select the Account with the trouble and click Change
4) Click on More Settings
5) Click on Outgoing Server Tab
6) Click "Outgoing Mail Server (SMTP) requires authentication" and make sure "Use same settings as incoming mail server" is selected (see attached image)
7) Click on "Advanced Tab"
8) Set outgoing Port (SMTP) to 26 (if your hosting account is Linux) or 587 if your hosting account is Windows.
9) Click Ok and then Test Account Settings

If it fails on send then repeat starting from 7.

7) Click on Advanced Tab
8) Set outgoing Port (SMTP) to 465 (See attached)
9) Check the box Beside "The server requires an encrypted connection (SSL)".
10 ) Click ok and then Test Account Settings

This is all well and good but it doesnt address the issue on the server (which is where the problem must be). This is only happening on some accounts, not all. The problem seems intermittant, IE it has sorted itself out by itself on one of my other servers. There must be a cause of the problem and a way of preventing it from happening in the future. Ive seen other people on here with the same problem, does anyone know how to fix it?

Cheers
 

dafut

Well-Known Member
Dec 14, 2005
74
0
156
The server is preventing unauthenticated users from sending mail through it; your server's doing what it's supposed to do.

The "fix" is exactly what's needed: users are required to authenticate prior to sending email. Have clients set their Outlook or other email client to use the same settings as the incoming server. That should fix it.

Although the server returns the error, it's actually a client configuration error.
 

Zion Ahead

Well-Known Member
Nov 10, 2006
347
0
166
I'm having this problem as well, but I'm using a vbulletin webmail hack. The hack itself works fine, buts the smtp authentication is messing up

Connection to mydomain.com:25....
Rcvd: 220-server.host.com ESMTP Exim 4.63 #1 Thu, 15 Feb 2007 08:30:58 -0600
Rcvd: 220-We do not authorize the use of this system to transport unsolicited,
Rcvd: 220 and/or bulk e-mail.
Sent: helo localhost
Rcvd: 250 server.host.com Hello localhost [xxx.xxx.66.3]
Sent: MAIL FROM:Forums
Rcvd: 501 Forums: missing or malformed local part (expected word or "<")
Sent: RCPT TO:[email protected]
Rcvd: 503 sender not yet given
Sent: DATA
Rcvd: 503 valid RCPT command must precede DATA
Sent: QUIT
Rcvd: 221 server.host.com closing connection
Rcvd:


I setup pop/smtp as mydomain.com 110 for pop3, 25 for smtp and [email protected] and password for login. For smtp auth type, I have "none", also tried "login".