The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sending mail from nobody

Discussion in 'E-mail Discussions' started by antec1981, Jul 20, 2006.

  1. antec1981

    antec1981 Registered

    Joined:
    Aug 20, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    When a php script im using send mails to an email in outlook some people see


    "Nobody [nobody@server15.XXXX.com]; on behalf of; XXXXXX Inc [billing@XXXXX.com]"


    when they open the mail. I would like to suppress this but im not sure how. I think it is due to phpmailer setting the "Sender" argument into the message headers.

    Is there a way for Exim to say hey if sender contains Nobody to pull in the X-Source-Dir: line up to ":" and do a rewrite of that address if From also includes billing. Or without phpsuexec enabled another way to have Exim detect the sender user and set it to their domain another way. If php can do this that would be ok also.
    aka

    Nobody <Nobody@server1.host.com> would become Billing <billing@$sourcedirhost>
     
  2. freedog96150

    freedog96150 Well-Known Member

    Joined:
    Mar 25, 2005
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Nevada, USA
    Goto WHM -> Service Configuration -> Exim configuration Editor -> Options and uncheck the option that says "Always set the Sender: header when the sender is changed from the actual sender. (Unchecking this will stop "On behalf of" data in Microsoft(R) Outlook, but may limit your ability to track abuse of the mail system.)"

    That should do it.
     
Loading...

Share This Page