The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sending mail via authentication stopped working overnight [case 50280]

Discussion in 'E-mail Discussions' started by jerrybell, Jun 1, 2011.

  1. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    I started seeing errors like this overnight (id obscured):
    535 Incorrect authentication data (set_id=test@test.org)
    in mainlog. This is happening to everyone who tries to send using authentication, on any domain on the system. Any ideas what could be wrong?
     
  2. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    So, it looks like lsearch of /etc/userdomains is failing... I started exim in debug mode and saw this:
    Code:
    10:26:34 25242 search_open: lsearch "/etc/userdomains"
    10:26:34 25242   cached open
    10:26:34 25242 search_find: file="/etc/userdomains"
    10:26:34 25242   key=""stelesys.com"" partial=-1 affix=NULL starflags=0
    10:26:34 25242 LRU list:
    10:26:34 25242   6/etc/userdomains
    10:26:34 25242   5/etc/relayhosts
    10:26:34 25242   5/etc/trustedmailhosts
    10:26:34 25242   6/etc/trustedmailhosts
    10:26:34 25242   End
    10:26:34 25242 internal_search_find: file="/etc/userdomains"
    10:26:34 25242   type=lsearch key=""stelesys.com""
    10:26:34 25242 cached data used for lookup of "stelesys.com"
    10:26:34 25242   in /etc/userdomains
    10:26:34 25242 lookup failed
    10:26:34 25242 expanding: $value
    10:26:34 25242    result:
    10:26:34 25242 skipping: result is not used
    10:26:34 25242 expanding: ${lookup{"stelesys.com"}lsearch{/etc/userdomains}{$value}}
    10:26:34 25242    result:
    10:26:34 25242 expanding: ${perl{checkuserpass}{$1}{$2}}
    10:26:34 25242    result: no
    10:26:34 25242 expanded string: no
    10:26:34 25242 expanding: $1
    10:26:34 25242    result: jerry@stelesys.com
    10:26:34 25242 SMTP>> 535 Incorrect authentication data
    This part:
    10:26:34 25242 expanding: ${lookup{"stelesys.com"}lsearch{/etc/userdomains}{$value}}
    10:26:34 25242 result:

    Should return the user name associated with stelesys.com, but does not and so the rest fails because it doesn't know where to go to look at the passwords.
     
  3. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    You can rebuild this file by running /scripts/updateuserdomains
     
  4. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    Thanks for the tip, Nick. Unfortunately, it didn't help. I can't see any problems with the format of the file. After running updateuserdomains, I get the very same problem when I look at the debug.
     
  5. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    I think the best bet is to open a ticket at https://tickets.cpanel.net/submit/ or from WHM and post the case number here.
     
  6. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    I have cpanel through a reseller, so I have requested my hosting provider to open the ticket. I will post the number once I have it.

    Thank you
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  8. xspace

    xspace Registered

    Joined:
    Jun 1, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    The same happen on my VPS after upgrade to 11.30 build 23 overnight. User can't authenticate via SMTP /535/, but can via Webmail.
     
  9. fdnven

    fdnven Well-Known Member

    Joined:
    Feb 14, 2006
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    SMTP issues after updates

    Hi,

    Currently production servers were up-dated to 11.30 stable (build23). After the update users are unable to send mail SMPT. The error is always the same Error message: "Login to server mail.********.net failed." Nothing has changed on the users end.

    I have tried the Fix Permissions and ended up with alot of :
    Fixed permissions of /home/*****/mail/***** : was (0751), now (0750)

    Still has not cured the SMPT issue.

    Thanks
     
  10. slago

    slago Registered

    Joined:
    Jun 1, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    Some problem here!!

    Now we can't send mail, and squirremail show:

    535 Incorrect authentication data

    I do a lot of things, update, fix demo files, etc... and nothing happend.

    Some idea?

    I open a ticket at least 3 hours and nothing happend. case ticket is 1559702
     
  11. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Re: SMTP issues after updates

    I believe you are having the same problem that I and a few others are having. I started a thread about it here. Cpanel support has been working on the issue for me. Hopefully we can figure out what is causing it soon.
     
  12. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Re: Sending mail via authentication stopped working overnight - possibly 11.30 upgrad

    Troubleshooting Steps. Try each step, then try authenticating again.
    • 1) Update to 11.30.0.25
    • 2) Make sure have imap enabled.
      WHM >> Service Configuration >> Service Manager
    • 3) Make sure courier and dovecot are set to "Inherit" and not "Never"
      WHM >> Server Configuration >> Update Preferences
    • 4) If you have not selected a mail server during the initial setup phase, please use the mail server selection tool to do this now.
      WHM >> Service Configuration >> Mailserver Selection
    • 5) Run the following in a root shell:
      Code:
      /scripts/mailperm
      
    • 6) Open a ticket using Support >> Contact cPanel or https://tickets.cpanel.net/submit/ and post the ticket # in this thread

    The SMTP auth problem is being investigated and has been assigned case 50280.

    We are aware servers still running mbox instead of maildir ceased to have functional mail upon upgrading to 11.30. August 1, 2008 was date support for mbox was discontinued. However, we plan on issuing an update to restore mbox functionality to 11.28 levels in the next 48 hours. The mbox fixes have been assigned case 50270.
     
  13. fdnven

    fdnven Well-Known Member

    Joined:
    Feb 14, 2006
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Your Request id is: 1562301
    And
    Support Request Id 1562325
     
  14. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    For those impacted by this problem, cpanel support provided a workaround... Change from courier to dovecot. I was quite skeptical that it would do anything to help, but after changing to dovecot, a new authenticator is added to exim, which is used to authenticate SMTP connections, and at least in my case, it's working. Here's how I fixed it:

    1. log in to WHM as root
    2. navigate to "mailserver selection"
    3. choose "dovecot" and click the "save" button. It takes a few minutes to complete and smtp authentication should start working.

    Best of luck to all
     
  15. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    We have released 11.30.0.25 which repairs the fallback code that is used when dovecot or courier is not available to authenticate. On a side note, I would personally recommend switching your server to dovecot as its performance is drastically better then courier in most situations.
     
  16. jerrybell

    jerrybell Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Thanks. I noticed that Thunderbird suddenly started telling my what % of my quota my mailbox is, and allegedly it worked better with blackberry as well. I think I'll be keeping it on dovecot as you recommend.
     
  17. rezman

    rezman Well-Known Member

    Joined:
    Feb 3, 2011
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I started having this problem 2 days ago so I found this thread and changed over to dovecot. It doesn't seem like it fixed my problem. Now the problem seem to randomly happen.. I myself am not able to reproduce it. Not every mailbox is having the problem. It always seems to be the same mail boxes that do and only with sending mail. I have ran the following with no luck:

    Code:
    /scripts/updateuserdomains
    /scripts/mailperm
    I'm running: WHM 11.30.0 (build 32)

    I have adjusted a few of the settings within "WHM >> Main >> Service Configuration >> Mailserver Configuration". Below are my current settings:

    Code:
    Protocols Enabled: IMAP IMAPS POP3 POP3S
    	
    Allow Plaintext Authentication: YES
    	
    SSL Cipher List:	ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:-SSLv2:-EXP
    	
    Maximum IMAP Connections Per IP:	20
    	
    Maximum POP3 Connections per IP:	20
    	
    Number of Spare Authentication Processes:	10  (was 5)
    	
    Maximum Number of Authentication Processes:	50
    	
    Size of Authentication Cache (KB):	1024
    	
    Time to Cache Successful Logins:	3600
    	
    Time to Cache Failed Logins:	3600
    	
    Use New Login Process for Each Connection:	NO
    	
    Idle Check Interval:	30
    
    Below is an example of running 'imap' and 'pop3'. It would almost appear as though they are not exiting once completed? Maybe this is normal. All 'xxxxxx' are processes spawned from user accounts. They never seem to exit or die off. The PID's never change. If I do a 'killall -9 imap' then new ones start to spawn but soon fills up.
    Code:
     3259 xxxxx     15   0  3108 1336 1084 S  0.0  0.0   0:00.00 imap
     3796 xxxx      15   0  3404 1820 1336 S  0.0  0.0   0:00.01 imap
     5559 dovecot   15   0  5396 1912 1540 S  0.0  0.0   0:00.04 pop3-login
     5560 dovecot   15   0  5396 1920 1544 S  0.0  0.0   0:00.05 pop3-login
     5561 dovecot   15   0  5396 1888 1540 S  0.0  0.0   0:00.03 pop3-login
     5562 dovecot   15   0  5320 1888 1540 S  0.0  0.0   0:00.06 pop3-login
     5563 dovecot   15   0  5396 1900 1540 S  0.0  0.0   0:00.04 pop3-login
     5565 dovecot   15   0  5396 1892 1540 S  0.0  0.0   0:00.01 pop3-login
     5567 dovecot   15   0  5296 1724 1416 S  0.0  0.0   0:00.00 pop3-login
     5570 dovecot   15   0  5396 1932 1544 S  0.0  0.0   0:00.27 pop3-login
     5571 dovecot   15   0  5452 2008 1544 S  0.0  0.0   0:00.64 pop3-login
     5572 dovecot   15   0  5396 1900 1544 S  0.0  0.0   0:00.07 pop3-login
     5573 dovecot   15   0  5336 1896 1548 S  0.0  0.0   0:00.01 imap-login
     5574 dovecot   15   0  5576 2072 1556 S  0.0  0.0   0:00.21 imap-login
     5575 dovecot   15   0  5604 2016 1536 S  0.0  0.0   0:00.04 imap-login
     5577 dovecot   15   0  5336 1892 1536 S  0.0  0.0   0:00.01 imap-login
     5578 dovecot   15   0  5476 1984 1568 S  0.0  0.0   0:00.04 imap-login
     5579 dovecot   15   0  5532 2004 1568 S  0.0  0.0   0:00.14 imap-login
     5580 dovecot   15   0  5560 2016 1556 S  0.0  0.0   0:00.08 imap-login
     5581 dovecot   15   0  5424 1932 1556 S  0.0  0.0   0:00.05 imap-login
     5582 dovecot   16   0  5600 2072 1568 S  0.0  0.0   0:00.25 imap-login
     5583 dovecot   15   0  5484 1992 1556 S  0.0  0.0   0:00.07 imap-login
     7745 xxxxxxxx  18   0  3116 1468 1200 S  0.0  0.0   0:00.00 imap
     8991 xxxxxxxx  15   0  3108 1428 1088 S  0.0  0.0   0:00.00 imap
     9012 xxxxxxx   15   0  3108 1436 1092 S  0.0  0.0   0:00.00 imap
    10409 xxxxxxxx  15   0  3132 1556 1168 S  0.0  0.0   0:00.00 pop3
    10417 xxxxxxxx  15   0  3144 1560 1168 S  0.0  0.0   0:00.00 pop3
    10530 xxxxxxxx  15   0  3368 1828 1284 S  0.0  0.0   0:00.01 imap
    13436 xxxxxxx   17   0  3116 1388 1104 S  0.0  0.0   0:00.00 imap
    13437 xxxxxxxx  17   0  3116 1388 1104 S  0.0  0.0   0:00.00 imap
    13442 xxxxxxx   15   0  3108 1500 1156 S  0.0  0.0   0:00.00 imap
    13448 xxxxxxxx  15   0  3108 1488 1144 S  0.0  0.0   0:00.00 imap
    13480 xxxxx     15   0  3124 1540 1184 S  0.0  0.0   0:00.00 imap
    13545 xxxxxx    18   0  3140 1448 1164 S  0.0  0.0   0:00.00 imap
    13557 xxxxxxxx  21   0  3228 1568 1172 S  0.0  0.0   0:00.00 imap
    13559 xxxxxxxx  17   0  3244 1716 1244 S  0.0  0.0   0:00.00 imap
    13560 xxxxxxxx  16   0  3140 1464 1160 S  0.0  0.0   0:00.00 imap
    13561 xxxxxxxx  17   0  3132 1464 1156 S  0.0  0.0   0:00.00 imap
    13618 xxxxxxxx  17   0  3328 1840 1356 S  0.0  0.0   0:00.00 imap
    13744 xxxxxxxx  16   0  3240 1696 1240 S  0.0  0.0   0:00.00 imap
    22380 xxxxxxxx  16   0  3116 1416 1144 S  0.0  0.0   0:00.00 imap
    24721 xxxxxxxx  15   0  4916 2752 1368 S  0.0  0.1   0:00.16 imap
    26189 xxxxxxxx  16   0  2972 1064  912 S  0.0  0.0   0:00.00 imap
    26300 xxxxxxxx  15   0  3224 1636 1184 S  0.0  0.0   0:00.00 imap
    27275 xxxxxxxx  15   0  3020 1372 1104 S  0.0  0.0   0:00.00 pop3
    31773 xxxxxx    17   0  3952 2064 1356 S  0.0  0.0   0:00.08 imap

    Another problem that I'm able to reproduce every time with Mozilla Thunderbird is, if an account has "STARTTLS" selected then they are getting a certificate error. This is because they are connecting using 'mail.theirdomain.com' but the SSL cert is for 'cpanelX.myserver.com' domain. Disabling 'STARTTLS' or changing the incoming/outgoing mail servers to 'cpanelX.myserver.com' will prevent this. Also accepting the cert works as well. This whole problem just started as well.


    Any input would be helpful as many clients are having trouble with mail.
     
Loading...

Share This Page