The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

sendmail not working

Discussion in 'E-mail Discussions' started by mpi, Apr 7, 2006.

  1. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    okay, so i was just going through some of my scripts and i noticed that sendmail isn't working.

    it can NOT send emails to the outside but it CAN send emails to for example webmaster@mydomain.com

    also, if it makes any difference i CAN send emails to the outside using Neomail or any of the other two.

    has this happened to anyone else? and if so, how did you fix it?
     
  2. ullalla

    ullalla Well-Known Member

    Joined:
    Jan 20, 2006
    Messages:
    192
    Likes Received:
    0
    Trophy Points:
    16
    one of the reason

    Hi,

    If you are facing the problem about the Earthlink, MSN and AOL then follwing is one of the reason:

    Earthlink, MSN and AOL users can have problems using their domains SMTP (send mail) server because of safe guards these ISPs have in place to prevent spammers from using their services.

    You will need to use your ISP's SMTP mail server information in place of your own server information when setting up your email application. This will not affect your incoming mail.

    Thank you :)

    Ullalla
     
  3. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    dsadsa

    and by that i mean the

    mail($address,$subject,$message) function

    can this have anything to do with the DNS servers...?

    i'd appreciate it if anyone can help me with these.
     
  4. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    thx

    hi, i just saw your post right now :rolleyes:

    thx buti'm actually sending it to my own other email address hosted on another server at my domain name...that ne using cpanel also but i'm just paying for a shared space on that server.....and it doesn't have a spam blocker.

    it's just having problems getting the email out, because it can send emails around within the servers but not to the outside.
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You'd need to check the exim mainlog on the server and make sure that /etc/eximmailtrap doesn't exist and is set to 0 in /var/cpanel/cpanel.config. If you're not the server admin, then you need to speak to your web hosting provider.
     
  6. mpi

    mpi Well-Known Member

    Joined:
    Mar 29, 2006
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    das

    THANK YOU MAN!

    worked :)
     
  7. andyogsc

    andyogsc Member

    Joined:
    Mar 6, 2004
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Does this stop your server from trying to send out spam that doesn't exist. And stop it from sending it back to itself.
     
Loading...

Share This Page