The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Serious Problem with cpanel and whm & upcp

Discussion in 'General Discussion' started by EdRooney, Dec 17, 2004.

  1. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    Cpanel wont load fully. It stops at "Hosting package"

    Many features in WHM dont work, change a sites ip, etc

    upcp, will not run, no error, it just hangs.

    This is what i get when I strace /scripts/upcp
    --- SIGCHLD (Child exited) ---
    rt_sigaction(SIGINT, {SIG_DFL}, NULL, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_DFL}, NULL, 8) = 0
    read(3, "", 4) = 0
    close(3) = 0
    pipe([3, 4]) = 0
    fork() = 2692
    close(4) = 0
    rt_sigaction(SIGINT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    wait4(2692, [WIFEXITED(s) && WEXITSTATUS(s) == 0], 0, NULL) = 2692
    --- SIGCHLD (Child exited) ---
    rt_sigaction(SIGINT, {SIG_DFL}, NULL, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_DFL}, NULL, 8) = 0
    read(3, "", 4) = 0
    close(3) = 0
    pipe([3, 4]) = 0
    fork() = 2694
    close(4) = 0
    rt_sigaction(SIGINT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    wait4(2694, [WIFEXITED(s) && WEXITSTATUS(s) == 1], 0, NULL) = 2694
    --- SIGCHLD (Child exited) ---
    rt_sigaction(SIGINT, {SIG_DFL}, NULL, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_DFL}, NULL, 8) = 0
    read(3, "", 4) = 0
    close(3) = 0
    stat64("/usr/local/lib/php.ini", {st_mode=S_IFREG|0644, st_size=23608, ...}) = 0
    stat64("/usr/lib/php.ini", {st_mode=S_IFREG|0644, st_size=23608, ...}) = 0
    stat64("/usr/bin/sum", {st_mode=S_IFREG|0755, st_size=27340, ...}) = 0
    stat64("/bin/sum", {st_mode=S_IFREG|0755, st_size=27340, ...}) = 0
    stat64("/usr/bin/nano", 0x8116760) = -1 ENOENT (No such file or directory)
    stat64("/usr/local/bin/spamd", 0x8116760) = -1 ENOENT (No such file or directory)
    stat64("/usr/local/bin/spamc", 0x8116760) = -1 ENOENT (No such file or directory)
    stat64("/usr/local/bin/expect", 0x8116760) = -1 ENOENT (No such file or directory)
    stat64("/usr/local/cpanel/base/openwebmail", 0x8116760) = -1 ENOENT (No such file or directory)
    stat64("/etc/make.conf", 0x8116760) = -1 ENOENT (No such file or directory)
    pipe([3, 4]) = 0
    fork() = 2696
    --- SIGCHLD (Child exited) ---
    close(4) = 0
    rt_sigaction(SIGINT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    wait4(2696, [WIFEXITED(s) && WEXITSTATUS(s) == 0], 0, NULL) = 2696
    rt_sigaction(SIGINT, {SIG_DFL}, NULL, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_DFL}, NULL, 8) = 0
    read(3, "", 4) = 0
    close(3) = 0
    pipe([3, 4]) = 0
    fork() = 2697
    close(4) = 0
    rt_sigaction(SIGINT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    rt_sigaction(SIGQUIT, {SIG_IGN}, {SIG_DFL}, 8) = 0
    wait4(2697,

    Why is it stoping here:
    wait4(2697,
    WTF???
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Use the -f flag with strace as its waiting for a child you can't see
     
  3. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    Thanks, this is what it gives me now.

    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] time([1103339627]) = 1103339627
    [pid 5664] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    [pid 5664] rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    [pid 5664] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid 5664] nanosleep({1, 0}, {1, 0}) = 0
    [pid 5664] time([1103339628]) = 1103339628
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] time([1103339628]) = 1103339628
    [pid 5664] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    [pid 5664] rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    [pid 5664] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid 5664] nanosleep({1, 0}, {1, 0}) = 0
    [pid 5664] time([1103339629]) = 1103339629
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] time([1103339629]) = 1103339629
    [pid 5664] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    [pid 5664] rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    [pid 5664] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid 5664] nanosleep({1, 0}, {1, 0}) = 0
    [pid 5664] time([1103339630]) = 1103339630
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] stat64("/usr/local/apache/conf/httpd.conf.lock", {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 5664] time([1103339630]) = 1103339630
    [pid 5664] rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
    [pid 5664] rt_sigaction(SIGCHLD, NULL, {SIG_DFL}, 8) = 0
    [pid 5664] rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
    [pid 5664] nanosleep({1, 0}, <unfinished ...>

    Is it saying its waiting for this file? /usr/local/apache/conf/httpd.conf.lock ?

    I remove it and it sticks on:
    [pid 6659] fstat64(3, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
    [pid 6659] fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
    [pid 6659] close(3) = 0
    [pid 6659] open("/usr/local/apache/conf/httpd.conf", O_RDONLY|O_LARGEFILE) = 3
    [pid 6659] fstat64(3, {st_mode=S_IFREG|0644, st_size=565455, ...}) = 0
    [pid 6659] fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
    [pid 6659] stat64("/usr/local/apache/conf/httpd.conf", {st_mode=S_IFREG|0644, st_size=565455, ...}) = 0
    [pid 6659] flock(3, LOCK_EX

    What does this tell me? ??? :confused: ???
     
  4. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    bump......
     
  5. Immortal

    Immortal Member

    Joined:
    Oct 14, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I am also having this same issue, as CPanel's main page doesn't want to load. :(
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    What version are you running?
     
  7. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Please post the results of

    # /usr/sbin/lsof -n |grep httpd.conf

    if You don't have lsof installed run

    # /scripts/ensurerpm lsof
     
  8. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    WHM 9.9.9 cPanel 9.9.9-E24
    RedHat 7.3 i686 - WHM X v3.1.0

    # /usr/sbin/lsof -n |grep httpd.conf
    checksusp 6659 root 3r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    whostmgr2 11625 root 4r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    whostmgr2 21667 root 4r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    checksusp 23533 root 3r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    whostmgr2 24159 root 4r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    whostmgr2 25368 root 4r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    safeapach 26614 root 0u REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    safeapach 26614 root 2r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    killdrroo 28123 root 3r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    whostmgr2 28377 root 5u REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    whostmgr2 30069 root 5r REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
    apachelim 31308 root 3u REG 8,5 565455 323246 /usr/local/apache/conf/httpd.conf
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Looks like something is stuck. Please open a ticket and post the number. I will get to it tonight if you post it ASAP.
     
  10. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    Ticket #83705
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    It looks like the locks on httpd.conf backed up in line because it was waiting for a process you were stracing to be terminated which had a lock on httpd.conf
     
  12. EdRooney

    EdRooney BANNED

    Joined:
    Oct 21, 2004
    Messages:
    166
    Likes Received:
    0
    Trophy Points:
    0
    Thanks working good now!
     
Loading...

Share This Page