Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Serious problem with mail

Discussion in 'E-mail Discussion' started by webebo, Feb 6, 2006.

  1. webebo

    webebo Registered

    Joined:
    Sep 11, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    I have looked for threads here that might have my problem, but have been unable to do so. I have tried restarting exim and this is what I get:

    Shutting down exim: FAILED
    Shutting down antirelayd: OK
    Shutting down spamd: OK
    Starting exim: 2006-02-06 23:33:46 Exim sonfiguration error in line 867 of /etc/exim.conf: missing error type FAILED

    Starting exim-smtps: 2006-02-06 23:33:46 Exim configuration error in line 867 of /etc/exim.conf: missing error type FAILED

    Starting antirelayd: OK
    Starting spamd: OK

    In an effort to reject invalid emails, I changed one thing in the exim.conf file. After the 'accept domains =+local_domains' I changed the following:

    message = "The recipient cannot be verified. Please check all recipients of this message to verify they are valid."

    to

    message = unknown user

    When the calls started rolling in that email was not coming in, I went back to change the setting.

    I have been unable to get email to flow since. I do not have a backup of the file, that I know of. Is there a way to reset the file back to its original state? I need this up and running asap. Any help would be much appreciated.

    I have tried running /scripts/fixmailman
    rebooting server
    restarting exim

    Can't think of anything else to do.

    Please help.

    webebo
     
  2. manokiss

    manokiss Well-Known Member

    Joined:
    Mar 31, 2002
    Messages:
    575
    Likes Received:
    0
    Trophy Points:
    316
    Do not edit the exim.conf from shell, edit and change it back from WHM exim config editor.
    Then restart it.

    If that dont work do /scripts/eximup --force

    hope this help
     
  3. webebo

    webebo Registered

    Joined:
    Sep 11, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    Didn't work. Either one. It tells me that eximup --force is not valid. It is not a recongized command. Anything else.
     
  4. xerophyte

    xerophyte Well-Known Member

    Joined:
    Mar 16, 2003
    Messages:
    216
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Canada
    backup all the /etc/exim* files to some place and do /scripts/eximup --force


    the script located in the /scripts/eximup .. so please call it
    Code:
      /scripts/eximup --force 
    
    that above will reinstall the exim with default cpanel configuration

    hope that helps
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice