Serious problems after V11 and maildir

Cystrix

Member
Sep 11, 2003
5
0
151
Im stuck in a bit of a pickle here. After the server updated to version 11, email no longer works for any domain. The mail has been upgraded to maildir.

exim -bt gives me the following:

# exim -bt [email protected]
[email protected]
router = virtual_sa_user, transport = virtual_sa_userdelivery

# exim -bt [email protected]
[email protected] is undeliverable:
unrouteable mail domain "gmail.com"

I have disabled all the options for checking sender exists in whm > exim > conf.
The resolv.conf is correct.

When I send an email from gmail to the server I get:

exim/mainlog:
2007-06-17 15:18:57 H=(ug-out-1314.google.com) [66.249.92.173] sender verify fail for <[email protected]>: unrouteable mail domain "gmail.com"
2007-06-17 15:18:57 H=(ug-out-1314.google.com) [66.249.92.173] F=<[email protected]> rejected RCPT <[email protected]>: Sender verify failed

exim/rejectlog:
2007-06-17 15:18:57 H=(ug-out-1314.google.com) [66.249.92.173] sender verify fail for <[email protected]>: unrouteable mail domain "gmail.com"
2007-06-17 15:18:57 H=(ug-out-1314.google.com) [66.249.92.173] F=<[email protected]> rejected RCPT <[email protected]>: Sender verify failed


When I send email from the server to gmail I get:

exim/mainlog:
2007-06-17 15:21:49 1HzvdV-000Imo-0Z <= [email protected] H=85-210-10-184.dsl.pipex.com ([10.0.2.6]) [85.210.10.184] P=esmtpa A=fixed_plain:[email protected] S=611 [email protected]
2007-06-17 15:21:49 1HzvdV-000Imo-0Z ** [email protected] R=fail_remote_domains: unrouteable mail domain "gmail.com"
2007-06-17 15:21:49 1HzvdV-000Imq-4y <= <> R=1HzvdV-000Imo-0Z U=mailnull P=local S=1458
2007-06-17 15:21:49 1HzvdV-000Imo-0Z Completed
2007-06-17 15:21:49 1HzvdV-000Imu-8g <= <> U=periton P=local-bsmtp S=1824 [email protected]
2007-06-17 15:21:50 1HzvdV-000Imu-8g => ben <[email protected]> R=virtual_user T=virtual_userdelivery
2007-06-17 15:21:50 1HzvdV-000Imu-8g Completed
2007-06-17 15:21:50 1HzvdV-000Imq-4y => ben <[email protected]> R=virtual_sa_user T=virtual_sa_userdelivery
2007-06-17 15:21:50 1HzvdV-000Imq-4y Completed

But I dont get the bounced message. In fact, sending from [email protected] to [email protected] results in:

exim/mainlog:
2007-06-17 15:27:12 1Hzvii-000Inv-6Z <= [email protected] H=([10.0.2.6]) [85.210.10.184] P=esmtpa A=fixed_plain:[email protected] S=553 [email protected]
2007-06-17 15:27:12 1Hzvii-000Io0-9t <= [email protected] U=periton P=local-bsmtp S=917 [email protected]
2007-06-17 15:27:12 1Hzvii-000Io0-9t => ben <[email protected]> R=virtual_user T=virtual_userdelivery
2007-06-17 15:27:12 1Hzvii-000Io0-9t Completed
2007-06-17 15:27:12 1Hzvii-000Inv-6Z => ben <[email protected]> R=virtual_sa_user T=virtual_sa_userdelivery
2007-06-17 15:27:12 1Hzvii-000Inv-6Z Complete

But popping in doesnt show any new messages.

Does anyone have any suggestions?!
 
Last edited:

cPanelNick

Administrator
Staff member
Mar 9, 2015
3,481
35
208
cPanel Access Level
DataCenter Provider
Dump your callout database in /var/spool/exim/db/callout*

Then check your /etc/resolv.conf to make sure all the nameservers respond quickly.
 

Cystrix

Member
Sep 11, 2003
5
0
151
Thanks for the reply.

All the nameservers are responding quickly and correctly.

I cannot find the callout databse.

[[email protected]:/var/spool/exim/db] # ls -al
total 3012
drwxr-x--- 2 mailnull mail 512 Oct 1 2004 ./
drwxr-x--- 6 mailnull mail 512 Oct 1 2004 ../
-rw-r----- 1 mailnull mail 704512 Jun 17 06:00 retry
-rw-r----- 1 mailnull mail 0 Sep 29 2004 retry.lockfile
-rw-r----- 1 mailnull mail 2949120 Jun 17 06:00 wait-remote_smtp
-rw-r----- 1 mailnull mail 0 Oct 1 2004 wait-remote_smtp.lockfile

Could that be the problem?
 

kenhawkins

Member
Jan 12, 2007
5
0
151
any response?

i ran the convert2maildir on Cpanel V11 and now cannot send mail out of the box! going back (reverting to mbox doesn't appear to clear it up. did you get any response on this?

I did notice that my resolv.conf had a serach and NOT a search entry in it.