The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

server certificates and IE7

Discussion in 'General Discussion' started by dory36, Nov 5, 2006.

  1. dory36

    dory36 Well-Known Member

    Joined:
    Aug 30, 2003
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Maybe it is IE7, maybe the server...

    No matter what I do, I get either a server name mismatch or untrusted CA alert in IE7 when visiting https:.../whm on my servers.

    I have reset the whm.cpanel certs, installed the certs in IE7, restarted cpanel, and everything else I have seen in the somewhat related messages I have been able to find.

    Any suggestions?

    Thanks,
    Bill
     
  2. adept2003

    adept2003 Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ~ "/(extra|special)/data"
    the ssl certificates generated by whm are self-signed, so you will always get the "untrusted" message. if you want to get rid of this, you will need to purchase and install an ssl certificate from a recognised source (i.e. verisign, geotrust, etc).

    however, if your customers log in via their own domain name followed by /whm or /cpanel, the ssl will not work, since it is always linked to just one FQDN (domain name) and IP.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Tools > Internet Options > Advanced Tab > Scroll to bottom, uncheck "Warn about certificate address mismatch"

    That should let you by ok.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It could also be that if you previously used IE6 you might have installed the self-signed certificates in your browsers CA list. I haven't upgraded to IE7, but it is possible that it didn't carry over such certs, especially if they seem "unsafe."
     
  5. c4n

    c4n Registered

    Joined:
    Sep 9, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
  6. mdhoffa

    mdhoffa Registered

    Joined:
    Apr 24, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    if you have a cert

    I have the same issue, where the browser tells me the certificate does not match my domain. However, I have a certificate and only need to login to WHM under one domain. So, I want to use that domain's certificate as the WHM certificate.

    There is a command in WHM that appears to change the cPanel certificate:

    > Main >> SSL/TLS >> Change Server Certificates

    That link gives this prompt:

    > Please select a server to change the certificate for:
    > cPanel/WHM Server

    Then, the page shows the form for installing certificates. It hasn't worked for me yet. I get this error:

    > Install SSL Certificates for Application: cpanel
    > Attempting to verify your certificate.....
    > Modulus mismatch, key file does not match certificate. Please use the correct key file

    Did anyone else have this issue?
     
  7. c4n

    c4n Registered

    Joined:
    Sep 9, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Make sure you access WHM under the correct domain. For example if the certificate is for "domain.com" then it must be accessed using "https://domain.com" and not "www.domain.com" or "host.domain.com" or any other.

    If you get an "untrusted certificate" error rather than not matching domain names you can try the solution suggested above.
     
Loading...

Share This Page