Server Contact Manager for Root not working correctly on new server

mpkapadia

Active Member
Apr 10, 2002
41
0
306
Servers hostname is server01.actualdomainname.com

Above FQDN Resolves correctly.

In Server contact manager the roots email are set to go to : [email protected]
Nobody and Cpanel emails are also set to go to : [email protected]

While I get the cpanel emails I do not get the root emails.
In the server queue I find the roots emails

from : [email protected]
to : [email protected]

Digged the same in detail via logging on to ssh

/root/.forward has the email address correctly entered .

However it does not seem to be getting picked up.

What else do I check.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Hello :)

Are you sure the messages in the mail queue are recent? Have you tried having a root email generated to see if the issue continues since the change was made to the root forwarding address?

Thank you.
 

mpkapadia

Active Member
Apr 10, 2002
41
0
306
Hello Michael,

I am 100 % sure that new root mails are also getting generated with From and To address as [email protected]
Since I have CSF installed it would also send an alert when I would say login via ssh and change as super user.
So those emails are getting generated on the server , and remain in queue.

Let me know where next to check . OR if you want me to run and particular repair script on the server.

Thanks.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,201
363
Feel free to open a support ticket if the messages generated by root and sent to the root address are not getting forwarded successfully. You can post the ticket number here so we can update this thread with the outcome.

Thank you.
 

quietFinn

Well-Known Member
Feb 4, 2006
1,222
87
178
Finland
cPanel Access Level
Root Administrator
In WHM -> Email -> Mail Queue Manager
see the "Actions" column of those root emails, do you have the "View history" icon there?
If yes then click it and see what it says.