Server crash after /scripts/upcp still not solved ?

Hostbox.be

Well-Known Member
Nov 4, 2002
61
0
156
I have this problem with my new server since last week, every other day the server hangs after /scripts/upcp in CRON. Only ping does still work and only a power reboot brings the server back online.

I have CentOS 3.4 installed with kernel 2.4.21-27.0.1
Latest stable release of cpanel: WHM 10.0.0 cPanel 10.0.0-R7
It's a servelinux server L4 with two IDE hard drives in RAID 1

FYI: I upgraded my perl version just after the fresh installation to:
This is perl, v5.8.4 built for i686-linux
perl-5.8.0-88.9 (rpm version)


So now every 2 days, I have to reboot my server at night around 4am, just after /scripts/upcp ?

What is going on because I am not the single user who has this problem ?
And I cannot see what's on the screen when the server crashes, because the server is 2 hours driving from my home.

What can I do ?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
1. Make sure that the cpbackup upcp and daily (04:00) cron jobs are spaced well apart

2. Disable smart disk checking:

touch /var/cpanel/disablesmartcheck

Might help.
 

anup123

Well-Known Member
Mar 29, 2004
889
1
168
This Planet
I would suggest shifting from auto transmission to floorshift gears :)
upcp auto has always been a nightmare for me.


Anup
 

Hostbox.be

Well-Known Member
Nov 4, 2002
61
0
156
These are my update configs in WHM:

cPanel/WHM Updates: Manual Updates Only (STABLE tree)
cPanel Package Updates: Automatic
Security Package Updates: Automatic

Should I change this or not ?


In my CRON list I have:
58 3 * * * /scripts/upcp
0 1 * * * /scripts/cpbackup

So, my backup starts at 1am and upcp at 3h58am.
BUT my backup takes a long time and ends always around 6am, so backup is still busy when upcp is called. Is that a problem or not ?
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
31
473
Go on, have a guess
In my CRON list I have:
58 3 * * * /scripts/upcp
0 1 * * * /scripts/cpbackup
That could be the source of your problems, then. Especially with upcp running at nearly 04:00.

For starters I'd suggest that you move the /scripts/upcp job to 23:00. That way, it is finished and done before the backups or the 04:00 daily job runs. See how that goes.