Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SERVER CRASH: configure backup....suggestions?

Discussion in 'General Discussion' started by I Love Jesus, Dec 11, 2004.

  1. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    156
    Three times in the last 2 months my server crashed (or locked up) during backups. I have my settings below. Any help to prevent this from happneing is appreciated.


    Backup Status: enabled
    Backup Interval: daily
    Backup Retention: daily
    Days to run backup: (all 7 days)
    Remount/Unmount backup drive: disabled
    Bail out if the backup drive cannot be mounted: disabled
    Incremental backup: disabled
    Backup Accounts: enabled
    Backup Config Files: enabled
    Sql Databases: per accounts and entire mysql database
    Backup Raw Access Logs: disabled
    Backup Type: standard
    Ftp Backup Host (Remote Ftp Backup Only) = empty
    Ftp Backup User (Remote Ftp Backup Only) = empty
    Ftp Backup Pass (Remote Ftp Backup Only) = empty
    Ftp Backup Directory/Path = empty
    Use Passive mode for Ftp transfers: enabled

    Specs:
    Pentium IV 2.4GHz
    1GB RAM
    Enterprise 3.3
    cPanel 9.9.9 R-10

    Disk usage:
    /dev/hda3 (primary) 11GB (17%)
    /dev/hdc1 (backup) 17GB (24%)

    I don't understand how the backup has more space used than primary. Anyone can explain this? Thanks.
     
  2. I Love Jesus

    I Love Jesus AKA chadi

    Joined:
    Dec 6, 2004
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    156
    I'm desperate for help, the night is close for the usual daily backup and I do not want my server to crash again :(

    Someone please help.
     
  3. racomnet

    racomnet BANNED

    Joined:
    Oct 6, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    156
    I think

    I think you server crash because of high load of cpu
    Try to change this value to enable
    Incremental backup: disabled

    If you set daily backup then in /backup/ you have daily, monthly, weekly and that why is more space ocupied on hdd.
    Try this
    SSH to your server :
    top to see what is eating you cpu. If it is cpbackup
    then to that
    lsof |grep back
    kill -9 pid of what is listen then
    ps -aux|grep pk
    and kill -9 the procese listen there. Should be someting like this: pkgacct
    Right now the backup procces is stoped.
    Ps: Do this on your risk.
    I have almost the same problem. Now I don't know how to start backup. To work with incremental. I will wait one more night to see what is happening.
    Hope this will help u a little.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. myrem

    myrem Well-Known Member

    Joined:
    Jul 14, 2002
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    156
    Make sure you are running the latest linux kernal... I was having a similar problem from excessive IOwaits that turned out to be a buggy kernal issue. The account package script is extremely disk intensive.

    The latest kernel for RHE 3 is 2.4.21-20.
     
  5. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    532
    Likes Received:
    0
    Trophy Points:
    166
    Actually, the latest standard kernel for RHEL is 2.4.21-20.0.1
     
  6. alexisb

    alexisb Active Member

    Joined:
    May 25, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    151
    Problems with backup and cpu load

    Hi, I am also getting high cpu loads with backup, I put:

    Backup Status: disabled

    in WHM, but I am still seeing:

    12171 root 39 19 584 524 504 R N 99.9 0.0 689:09 0 tar cfzp /backup/cpbackup/daily/dirs/_var_named.tar.gz /var/named
    12165 root 39 19 576 520 504 R N 99.6 0.0 689:41 0 tar cfzp /backup/cpbackup/daily/dirs/_etc_proftpd.tar.gz /etc/pro

    in top.

    It seems WHM is not using my configuration, how do I activate my changes for backup configuration?

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    166
    I am having the same issue. Playing with the following setting in tweak settings did help in the past, but now the issues are back:

    The load average above the number of cpus at which logs file processing should be suspended (default 0):

    Any help would be appreciated. Tonight my server already crashed after creating the files directory.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice