The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server generated emails to same server gets delivered to root

Discussion in 'E-mail Discussions' started by fairmount, Sep 2, 2012.

  1. fairmount

    fairmount Registered

    Joined:
    Sep 2, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I am quite new to cPanel. I have installed WHM and have created a cpanel account for a mydomain.co.uk.

    I have installed opencart on mydomain.co.uk. When ever an email is generated to a user in mydomain.co.uk, (for e.g. lost password, return request, any email sent from contact form) they get sent to the whm root email.

    If an email is sent to contact@mydomain.co.uk from another server, it gets delivered properly. But if an email is generated by mydomain.co.uk to contact@mydomain.co.uk or user@mydomain.co.uk, they get delivered to the root email and not to respective emails. emails sent to emails in other servers are being sent properly.

    The email (MX) is handled by 123-reg.

    The MX record on the domain registrar (123-reg) is set to 123reg server.
    I have noticed teh settings in cpanel. this is set to Automatically detect. The MX record in cpanel points only to mydomain.co.uk

    Can someone help me what settings i need to have to make sure self generated emails are handled properly please.

    Thanks,
    FM
     
    #1 fairmount, Sep 2, 2012
    Last edited: Sep 2, 2012
  2. Eric

    Eric Administrator
    Staff Member

    Joined:
    Nov 25, 2007
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    18
    Location:
    Texas
    cPanel Access Level:
    Root Administrator
    Howdy,

    It sounds like cPanel is assuming mydomain.co.uk is located on the server but it is located somewhere else. You may need to remove the auto-detect option from the domain and force it to the correct setting.

    The messages are likely going to root because they are tripple bounces. They can't go to address and they can't go back so they get dead-lettered to root's mailbox.

    If you are unable to work it out I would recommend opening a ticket and we would be happy to take a look.

    Thanks!
     
  3. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    • Go to Edit a DNS Record in WHM
    • Go to the domain which you want to edit
    • Right at the bottom instead of automatic, select: Remote Mail Server

    This should solve your problem.
     
  4. fairmount

    fairmount Registered

    Joined:
    Sep 2, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks Eric and ruzbehraja. This has solved the issue.

    I had assumed that I would receive an email as soon as I had a response to my question here. strangely I didn't and hence the late reply.
     
Loading...

Share This Page