The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Hanging... Pingable, but ALL Services Down!

Discussion in 'General Discussion' started by nitromax, Aug 25, 2003.

  1. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    I was wondering if anyone has ever seen this in the dmesg:

    EXT3-fs: INFO: recovery required on readonly filesystem.
    EXT3-fs: write access will be enabled during recovery.
    kjournald starting. Commit interval 5 seconds
    EXT3-fs: recovery complete.
    EXT3-fs: mounted filesystem with ordered data mode.
    hda: dma_timer_expiry: dma status == 0x21
    hda: error waiting for DMA
    hda: dma timeout retry: status=0xd0 { Busy }

    hda: DMA disabled
    ide0: reset: success


    In WHM on the status page it shows that /dev/hda3 and /dev/hda1 both have DMA next to them.

    My server has been hanging (not at any set time). It's pingable, but all services go down including SSH. The only thing that brings it back is a reboot.

    RackShack replaced the RAM yesterday, as a memory test did find it to be faulty, but it went down again today, so the problem still exists. I have run tests on the new memory and it checks out fine.

    I have read thru the forums all night, and I'm wondering if it has to do with the DMA error message above. It seems to be using a beta driver ( E-IDE driver Revision: 7.00beta3-.2.4 ). Is that right? Here's dmesg on that...


    Uniform Multi-Platform E-IDE driver Revision: 7.00beta3-.2.4
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ICH4: IDE controller at PCI slot 00:1f.1
    PCI: Found IRQ 10 for device 00:1f.1
    PCI: Sharing IRQ 10 with 00:02.0
    ICH4: chipset revision 2
    ICH4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:pio, hdd:pio
    hda: ST380011A, ATA DISK drive
    blk: queue c0377440, I/O limit 4095Mb (mask 0xffffffff)
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    hda: attached ide-disk driver.
    hda: host protected area => 1
    hda: 156301488 sectors (80026 MB) w/2048KiB Cache, CHS=9729/255/63, UDMA(100)


    I updated the kernel the day I got the server from 2.4.20-18.7 to 2.4.20-20.7 using up2date.

    Any idea? Would it help to try booting the original kernel that the server had on it? I'm lost... Thanks in advance if you can offer a suggesion...

    cPanel.net Support Ticket Number:
     
    #1 nitromax, Aug 25, 2003
    Last edited: Aug 25, 2003
  2. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    This is probably because your machine isn't compatible with the settings that cPanel has for DMA +. A WEB server can run fine with the default red hat settings for DMA. A server really only needs to be tuned if it's a FILE server. web servers are hit for small amounts of data, file servers stream data.

    edit /etc/rc.d/rc/local
    remove the lines:

    /scripts/hdparmon
    /scripts/hdparamify

    * Note you may only have one or the other or both of the above. Your file once you've finished editing it should look like this:
    Code:
    #!/bin/sh
    #
    # This script will be executed *after* all the other init scripts.
    # You can put your own initialization stuff in here if you don't
    # want to do the full Sys V style init stuff.
    
    touch /var/lock/subsys/local
    (sleep 10;/etc/rc.d/init.d/bandmin start)&
    rdate -s rdate.darkorb.net&
    Save, close & you will have to reboot for changes to take hold.

    cPanel.net Support Ticket Number:

    cPanel.net Support Ticket Number:
     
  3. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    Thanks! That worked pefectly! I also had a command in there to start Tomcat (which I uninstalled), so I removed that too.

    Do you think that was causing the server to hang as mentioned above, or does the fix you gave just remove the dma errors when I check dmesg?

    cPanel.net Support Ticket Number:
     
  4. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Removing those lines from the rc.local file will probably make your server 100% more reliable. The settings that cpanel has in those files is a little extreme for some hardware...and really a warning should be posted before enabling DMA +.

    cPanel.net Support Ticket Number:
     
  5. Dathorn_ADT

    Dathorn_ADT Active Member

    Joined:
    Nov 16, 2002
    Messages:
    41
    Likes Received:
    1
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Ours all still show the "DMA +" but no such lines exist in /etc/rc.d/rc.local on any of the servers. I'm only bringing this up as we've had a handful of servers die often as well, mostly during periods of high disk activity. Is there another way to disable it?

    cPanel.net Support Ticket Number:
     
  6. ciphervendor

    ciphervendor Well-Known Member

    Joined:
    Aug 26, 2002
    Messages:
    1,052
    Likes Received:
    0
    Trophy Points:
    36
    Removing those lines from the rc.local file and rebooting is the only way to disable DMA +. For some reason it still shows as active after reboot, but that's fine since it doesn't allow resellers, etc. to click the option. I would just ignore the system status page..

    cPanel.net Support Ticket Number:
     
  7. Dathorn_ADT

    Dathorn_ADT Active Member

    Joined:
    Nov 16, 2002
    Messages:
    41
    Likes Received:
    1
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Actually your best bet is to copy the /scripts/hdparmon script to a different location and change -d1 to -d0 to turn DMA off. This will then reflect accordingly in WHM. I'll know if this fixes my problem early tomorrow morning.

    cPanel.net Support Ticket Number:
     
  8. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    Just an update for me... Ever since I took that line of of the rc.local file as suggested above, my server has been rock steady! Not one crash, and chkservd has not had to restart even one service in the past week.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page