The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

server high demand

Discussion in 'General Discussion' started by bdraco, Sep 3, 2001.

  1. bdraco

    bdraco Guest

    [quote:8d2726c47c]On 3 or 4 of our Cpanel servers, Interchange seems to run at a decent load, but on one of our servers, it always takes up a high amount of memory. If we don\'t kill it, it\'ll bring down the server. We\'ve reinstalled Cpanel more times than we can count and each time, it does the same thing, and takes almost exactly the same amount of memory. We\'ve looked all over to find the problem and have compared everything against the other servers that work fine with it and there\'s absolutely no indication of why it\'s doing this. Interchange isn\'t the best tool anyway, and we have been looking into some better quality programs, until we get time to develop one. There\'s some pretty decent choices out there. [/quote:8d2726c47c]


    Have you tried upgrading perl to 5.6.1 and running /scripts/fixinterchange ?
     
  2. company name

    company name Registered

    Joined:
    Sep 3, 2001
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    SquidProxy here.... Yes, I always have the lastest, stable versions of all software. I\'m a big Perl programmer too, so I have all the latest as well as any relevant modules updated. I ran that script anyway and all it did, was check for various Perl modules, which were all up to date. I really don\'t see a script checking for something to trivial, as being a \"fix\" at all. I mean, Perl modules aren\'t going to make the Interchange process _always_ stay at a high load no matter what. I explained the rest in my above post, this script didn\'t help at all.. I could have updated the modules myself anyway. Like I said, it\'s a bit more complex than that sort of problem. And, like I said, it was at a high load, from the time it starts and it stays at a high load -- and I\'ve checked and done everything as outlined in my above post... this was certainly not an issue of an out of date module, nor a lack of a module. Trying to fix this, seems futile, and like I said, there\'s better options out there anyway... but no, that didn\'t help.
     
  3. bdraco

    bdraco Guest

    Have you tried stracing the interchange process to see what it is doing?
     
Loading...

Share This Page