Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Server Load

Discussion in 'General Discussion' started by tfcservices, Jul 31, 2003.

  1. tfcservices

    tfcservices Member

    May 22, 2003
    Likes Received:
    Trophy Points:
    I was wondering if someone could help me with this. I just started getting this e-mail that last few mornings. I just added several domains. There are currently about 101 domains on this server.

    Thanks in advance....

    IMPORTANT: Do not ignore this email.
    This is cPanel cpuwatch on server!
    While processing, the cpu has been
    maxed out for more then a 6 hour period. The current load/uptime line on the server at the time of
    this email is
    12:12am up 43 days, 6:13, 0 users, load average: 1.15, 0.29, 0.09
    You should check the server to see why the load is so high and take
    steps to lower the load. If you want stats to continue to run even with a high load; Edit
    /var/cpanel/cpanel.config and change extracpus to a number larger then 0 (run
    /usr/local/cpanel/startup afterwards to pickup the changes).

    This is also listed in my CPU/Memory usage

    Top Process %CPU 21.0 /usr/bin/perl /usr/bin/mrtg /etc/mrtg/mrtg.cfg
    Top Process %CPU 15.0 /usr/bin/perl /usr/bin/mrtg /etc/mrtg/mrtg.cfg

    What is this and should I be alarmed....

    Still learning... thanks, Support Ticket Number: Support Ticket Number:
  2. ciphervendor

    ciphervendor Well-Known Member

    Aug 26, 2002
    Likes Received:
    Trophy Points:
    Nothing really to be alarmed about, just an annoying notice. To make it go away:

    edit /var/cpanel/cpanel.config
    search for CPU
    replace the number (probably 0) with 3.
    execute /usr/local/cpanel/startup Support Ticket Number:
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. pkuk

    pkuk Well-Known Member

    Nov 16, 2002
    Likes Received:
    Trophy Points:
    I had this also, killed the greedy process and it went back to normal, although my process was vimconf. Don't know why it was doing it, but it's fine now and noone has reported any problems... Support Ticket Number:
  4. bjarne

    bjarne Well-Known Member

    Mar 23, 2002
    Likes Received:
    Trophy Points:
    It is normal that the load gets a litle high at times, and it is good to have this mail if the load is greater then 1 wich is deafult. The mail don't harm anyone :) It gives you some info how this server is doing. You can look at the values and ignore the warning - right?

    On a bussy server with a lot of backup and logfiles running it is wery importaint to check the load.

    BTW this mrtg lines is not a part of the cpanel setup, but I think it is deafult installed with RH if you install webserver.

    mrtg wi is used to create meassurments of bandwidh usage and create nice graphs etc. If you don't know what it is, I suggest you remove it.

    rpm -e mrtg or shuld have it removed.

    rpm -qa | grep mrtg will show it is installed, check and then remove and then check again and you are good. Support Ticket Number:
  5. PbG

    PbG Well-Known Member

    Mar 11, 2003
    Likes Received:
    Trophy Points:
    Tweak Settings - You can also change . . .

    The load average that will cause the server status to appear red (leave blank for default):

    I would increase this slowly and monitor your top processes in a ssh window often to get an idea just how high you can go. Support Ticket Number:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice