The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

server over load load average: 69.93

Discussion in 'General Discussion' started by alzoor, Dec 28, 2003.

  1. alzoor

    alzoor Registered

    Joined:
    Aug 7, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i have redhat 9 my server all the time over load and apache well be down i try easyapache sysup i check all my conf file
    i cant see ware is the problem any 1 can help me please
    -------------------------------------------------------------------
    17:30:30 up 1 day, 4:28, 1 user, load average: 29.32, 17.26, 14.07
    345 processes: 341 sleeping, 4 running, 0 zombie, 0 stopped
    CPU0 states: 84.1% user 13.6% system 0.0% nice 0.0% iowait 1.6% idle
    CPU1 states: 5.4% user 2.1% system 0.0% nice 0.0% iowait 92.1% idle
    Mem: 513164k av, 506584k used, 6580k free, 0k shrd, 8160k buff
    279204k actv, 61188k in_d, 10212k in_c
    Swap: 1052216k av, 406732k used, 645484k free 120304k cached
    ----------------------------------------------------------------------
    then
    21:00:09 up 1 day, 7:57, 1 user, load average: 69.93, 51.58, 32.48
    444 processes: 437 sleeping, 6 running, 0 zombie, 1 stopped
    CPU0 states: 86.6% user 1.4% system 0.0% nice 0.0% iowait 12.4% idle
    CPU1 states: 16.8% user 1.2% system 0.0% nice 0.0% iowait 82.4% idle
    Mem: 513164k av, 506544k used, 6620k free, 0k shrd, 9652k buff
    278340k actv, 60884k in_d, 10092k in_c
    Swap: 1052216k av, 426372k used, 625844k free 109776k cached
    -------------------------------------------------------------------
    then i restast apache and mysql it well be ok then

    21:00:54 up 1 day, 7:58, 1 user, load average: 64.28, 52.72, 33.78
    443 processes: 438 sleeping, 4 running, 0 zombie, 1 stopped
    CPU0 states: 114.0% user 0.0% system 0.0% nice 0.0% iowait 0.0% idle
    CPU1 states: 14.0% user 85.0% system 0.0% nice 0.0% iowait 0.0% idle
    Mem: 513164k av, 506764k used, 6400k free, 0k shrd, 9492k buff
    278644k actv, 61072k in_d, 10988k in_c
    Swap: 1052216k av, 431104k used, 621112k free 109580k cached
    ----------------------------------------------------------------------
    01:04:30 up 3:52, 1 user, load average: 114.46, 84.69, 58.26
    583 processes: 582 sleeping, 1 running, 0 zombie, 0 stopped
    CPU0 states: 2.0% user 2.4% system 0.0% nice 0.0% iowait 94.4% idle
    CPU1 states: 0.4% user 0.2% system 0.0% nice 0.0% iowait 98.4% idle
    Mem: 513164k av, 506440k used, 6724k free, 0k shrd, 9264k buff
    301244k actv, 66028k in_d, 10556k in_c
    Swap: 1052216k av, 506164k used, 546052k free 72616k cached



    thanks
     
    #1 alzoor, Dec 28, 2003
    Last edited: Dec 28, 2003
  2. jphilipson

    jphilipson Well-Known Member

    Joined:
    Jan 8, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Looks like you are swapping alot of memory. Whats causing it would need more info to figure out... are you running alot of scripted and mysql sites, and allowing mysql to use too muc memory.. lets have some specs on the server , then maybe we can help... but its apparent that memory use is too much. Just have to figure out why. In your cpanel, you can see what programs are using up the most cpu and ram
     
  3. alzoor

    alzoor Registered

    Joined:
    Aug 7, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i have 30 site on this server most off them they use forums
    this is my conf of my.cnf
    [client]
    port = 3306
    socket = /var/lib/mysql/mysql.sock

    [mysqld]
    port = 3306
    socket = /var/lib/mysql/mysql.sock
    skip-locking
    skip-innodb
    max_connections = 500
    #max_user_connections = 45
    key_buffer = 256M
    max_allowed_packet = 1M
    table_cache = 256
    sort_buffer_size = 1M
    read_buffer_size = 1M
    myisam_sort_buffer_size = 64M
    thread_cache = 8
    query_cache_size= 16M
    # Try number of CPU's*2 for thread_concurrency
    thread_concurrency = 8

    [mysqldump]
    quick
    max_allowed_packet = 16M

    [mysql]
    no-auto-rehash
    [isamchk]
    key_buffer = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M

    [myisamchk]
    key_buffer = 128M
    sort_buffer_size = 128M
    read_buffer = 2M
    write_buffer = 2M

    [mysqlhotcopy]
    interactive-timeout
    ======================
    and i have chick the apache conf its ok
    /usr/local/apache/bin/httpd -t
    Syntax OK
    ========================
    and i chang sum setting in apache
    RLimitMEM 103649280
    RLimitCPU 240
    Timeout 30
    KeepAlive On and i try Off
    MaxClients 250
    and i try MaxClients 400

    it well work fine for houre or sum time les then it well get over load.
     
    #3 alzoor, Dec 29, 2003
    Last edited: Dec 29, 2003
  4. jphilipson

    jphilipson Well-Known Member

    Joined:
    Jan 8, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    well the first thing i notice is the thread concurrency, unless you have 4 cpu's you are going to bottleneck, if its a single cpu, change that to 2... next, the key_buffer.. if you only have 512 ram, using 256 just for that is too much... change it to 100 or 150 , change the query cache to 32 maybe... but see hows those tweaks effect your performance.. but bottom line is that the system is swapping heavily, so more ram is gonna make a huge difference
     
  5. jphilipson

    jphilipson Well-Known Member

    Joined:
    Jan 8, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    and just to give a little clarity about all those settings in my.cnf...

    the sort, read and read_rnd buffer are not shared, so each connection uses a buffer. If you have each of those set to 1mb, then each connection will use 3 mb of ram... so if like you said, you have mostly forums, so ifyou had 200 connections to mysql, thats 600 mb ram... more than the machine has... so it starts swapping.. add to that a huge key buffer, and between the two your memory is gone. I think you simply need more ram, and change the settings as i mentioned... and add beneath

    read_buffer_size = 1M

    the following

    read_rnd_buffer_size = 768k
     
  6. alzoor

    alzoor Registered

    Joined:
    Aug 7, 2002
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    thanks jphilipson for your help

    i have change my.cnf setting
    and i well add more ram .
     
Loading...

Share This Page