The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

server setup confusion

Discussion in 'General Discussion' started by johndoe, Sep 4, 2002.

  1. johndoe

    johndoe Active Member

    Joined:
    May 26, 2002
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    dear forum members - finally succumbed to a server offer i couldn't refuse after 2 years reselling with cpanel | whm packages.

    thought i was comfortable enough for the &upgrade&, and was assured by the server seller whm should be enough. since i've used it so long, that made sense.

    but there's a problem somewhere that i don't quite understand having to do with the master server ip and the two ips i use for nameservers.

    i've been configuring namservers for my resold clients for quite a while now, so its almost routine. so here are the steps i took with my new server that lead to my current problem.

    1) from the server seller, i received this information (real numbers changed to protect the innocent (me), but the logic of the numbers are meant to allow continuity for comparison while analyzing this post):

    Master Server IP: 123.345.67.789 [the server seller gave me this number, but doesn't exactly know what's it for]
    Initial IPs for use with nameservers and/or dedicated domains:
    123.345.67.78
    123.345.67.79
    123.345.67.80
    123.345.67.81
    123.345.67.82
    123.345.67.83

    2) created nameservers at registrar:
    dns1.123.345.67.78 ==& dns1.sitename.net
    dns1.123.345.67.79 ==& dns2.sitename.com

    3) at registrar, pointed test domain to nameservers:
    testdomain.com ==&
    dns1.sitename.net
    dns2.sitename.com

    4) waited 72 hours to be safe.

    5) configured the server with whm:
    Primary IP Address: 123.345.67.789 (Master Server IP - not sure if this is correct IP for this space, or what's its purpose is, or its relationship to my server. running a lookup at arin resolves that ip to the netblock owner, but so do the other ips i was assigned (well, what did i expect?). i do not use this ip for nameserver assignment. the only place i could guess to use it was as the Primary IP Address)

    BIND Version: 8
    Master Cluster Server: [blank]
    Server Contact's AIM: johndoe
    Server Contact's E-Mail Address: admin@ispname.net
    Server Contact's Pager Address: [blank]
    Server Contact's ICQ UIN: [blank]
    Default CPanel4 Theme: advanced
    Default Home Directory: /home
    Home Directory Prefix: home

    Hostname: name.dns1.sitename.net [error pops up every time i logon to whm: &Hostname A Entry Missing!
    The server was unable to lookup an an A entry for its hostname (name.dns1.sitename.net). This is generally because the entry was never added. However this could also be the result of your nameserver(s) being down. If you would like to attempt to automaticlly add the entry, & - even though i did in fact add the entry. that text box initially said &localhost& before i changed it. whm gives nothing specific about changing it, other than offering some random hostname suggestions]

    Apache Access Log Style: combined
    Primary Nameserver: dns1.sitename.net
    Secondary Nameserver: dns2.sitename.com
    CGI Script Alias: y
    Master Nameserver: [i left this blank because i didn't know what to enter here, and didn't understand the attending message: &Enter the hostname or IP address of a primary nameserver (if this is not a primary nameserver.) that domain and subdomain updates should be sent to. If you turn this option on you will turn this server into a slave server. A trust key relationship must be established beforing entering the hostname (Optional).Examples: trusted.server.com, ns1.myhost.com, ns2.anotherhost.com&]&==the tech who installed my server didn't know what this was either because he's not a cpanel type of guy.

    i left out some of the config that was default to save space here.

    6) used whm to create a test package.

    7) used whm to add a test domain: test.com.

    8) used 'edit a dns zone' in whm to double check the dns settings for the test domain. results:

    @ 14400 IN SOA - - - dns1.sitename.net. - - - admin.ispname.net.

    Serial Number
    refresh
    retry
    expire
    minimum ttl

    Domain TTL RecordType
    test.com 14400 NS dns1.sitename.net.
    test.com 14400 NS dns2.sitename.com.
    test.com 14400 A 123.345.67.78
    localhost.test.com 14400 A 127.0.0.1 [this doesn't make sense to me]
    test.com 14400 MX 0
    mail 14400 CNAME test.com
    www 14400 CNAME test.com
    ftp 14400 CNAME test.com

    9) waited 48 hours to be safe.

    10) test.com only resolves in the browser when called as:
    http://123.345.67.78/~user/

    *phew*

    why am i here? because the server seller sells servers but doesn't know cpanel and whm. his only response to a request i made for help was, and i quote verbatim:

    Here's the best source of documentation available for Cpanel and WebHost Manager:
    http://www.cpanel.net/docs.htm
    Thanks for your business!
    Kind regards,
    U. R. Sucker

    [well... almost verbatim]

    any suggestions? thank you all in advance.

    diana
    aka johndoe :)
     
Loading...

Share This Page