The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server SSL

Discussion in 'General Discussion' started by eglwolf, May 27, 2005.

  1. eglwolf

    eglwolf Well-Known Member

    Joined:
    Jan 1, 2004
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    On my server the hostname is different from the server shared SSL.

    i.e.

    Hostname: xyz.servername.com
    Server Shared SSL: secure.servername.com

    I had an admin company set it up to work so that all cpanel secure logins and shared SSL for customers use the correct URL. However I am setting up a new server, and I would like to know how to do this myself.

    I have set up an account on a dedicated IP for the secure.servername.com and install the ssl under than account. I am just not sure how to allow for users to use that URL for the cpanel logins, and shared SSL.

    Can anyone point me in the right direction?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You need to go into WHM > SSL/TLS > Change cPanel/WHM Certificate > and enter the details for the certificate in the same way that you would have done for the cPanel account. You should then make sure that WHM > Tweak Settings > When visiting /cpanel or /whm or /webmail with ssl redirect to the servers hostname > is not checked.

    You should now be able to login to https://secure.serverdomain.com:2087 etc.
     
  3. HostIt

    HostIt Well-Known Member

    Joined:
    Feb 22, 2003
    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    18
    As I've just been through this myself, I need to add something to Chirpy's instructions..

    To force the change of server certificate, it is necessary to restart cPanel (which restarts cPanel SSL). Saving your 'Tweak Settings' will force cPanel to restart, so if you follow the order of Chirpy's instructions, you should be fine. Unfortunately for me I went in reverse order, and it took me a long time to realise I just needed to restart cPanel for it to work :)
     
    #3 HostIt, Nov 9, 2006
    Last edited: Nov 9, 2006
Loading...

Share This Page