server status missing info

S

Secret Agent

Guest
Just got an OS reload and updated cpanel to CURRENT.

Server status shows missing details.

Any fix to this?

Please see attached
 

Attachments

S

Secret Agent

Guest
Also the sites are showing the index directories instead of content.

I updated apache with php 4.4.1 and 4.4.0 several times as well.

Apache is up and running. Checked named.conf and NameVirtualHost is correct in httpd.conf

Ran these as well:

/scripts/fixvaliases
/scripts/fixcommonproblems
/scripts/rebuildnamedconf
/scripts/fixbuggynamed
/scripts/fixetchosts

service named restart

IP's are pinging, dns zones ok also.

[email protected] [~]# httpd configtest
Syntax OK
 

Zishan

Well-Known Member
Aug 6, 2005
107
1
168
Secret Agent said:
Just got an OS reload and updated cpanel to CURRENT.

Server status shows missing details.

Any fix to this?
Check from WHM >> Service Configuration >> Service Manager that the services are checked to display in the Service Status.

Also the sites are showing the index directories instead of content.
:confused: Didn't get what you mean???
 
S

Secret Agent

Guest
For example, you create a new account and dns is propagated but no data uploaded, it shows the default directories

Parent Directory 26-Nov-2005 19:14 -
_private/ 26-Nov-2005 16:15 -
cgi-bin/ 15-Sep-2005 17:48 -
images/ 15-Sep-2005 17:48 -
postinfo.html

It is not showing the site itself.

I've tried everything to fix it but to no avail
 

Zishan

Well-Known Member
Aug 6, 2005
107
1
168
Secret Agent said:
For example, you create a new account and dns is propagated but no data uploaded, it shows the default directories

Parent Directory 26-Nov-2005 19:14 -
_private/ 26-Nov-2005 16:15 -
cgi-bin/ 15-Sep-2005 17:48 -
images/ 15-Sep-2005 17:48 -
postinfo.html

It is not showing the site itself.

I've tried everything to fix it but to no avail
Did you placed an index file in public_html because if no index file is present the webserver will show the directory structure.However if you want that if the index page is not present then the webserver won't show the directory stucture then add this in .htaccess in public_html

Options –Indexes
 
S

Secret Agent

Guest
All the data is there. I did a restore on the account after the OS reload and every file is there as should be.
 
S

Secret Agent

Guest
I modifed httpd.conf and now one domain shows cpanel's green page "no website configured at this address"

Also, all the domains on the main shared IP (server's main IP) work fine except the two domains on their dedicated IP's.

The dns has been propagated for over 3 hours now.

NameVirtualHost xxx.x02.66.2:80


<VirtualHost xxx.x02.66.2>
BytesLog domlogs/server.domain.com-bytes_log
ServerName server.domain.com
DocumentRoot /usr/local/apache/htdocs
</VirtualHost>


<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Location>
ExtendedStatus On


<IfModule mod_rewrite.c>
RewriteEngine on
RewriteMap LeechProtect prg:/usr/local/cpanel/bin/leechprotect
</IfModule>


Here is the virtual host for one of the domains for example:


NameVirtualHost xxx.x02.66.3:80
<VirtualHost xxx.x02.66.3>
ServerAlias domain.com
ServerAdmin [email protected]
DocumentRoot /home/user/public_html
BytesLog domlogs/domain.com-bytes_log
User user
Group user
<IfModule mod_php4.c>
php_admin_value open_basedir "/home/user/:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_php5.c>
php_admin_value open_basedir "/home/user/:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_userdir.c>
UserDir disabled
UserDir enabled user
</IfModule>
ServerName www.domain.com

<IfModule mod_userdir.c>
Userdir disabled
Userdir enabled user
</IfModule>

<IfModule mod_php4.c>
php_admin_value open_basedir "/home/user:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_php5.c>
php_admin_value open_basedir "/home/user:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>

User user
Group user
CustomLog /usr/local/apache/domlogs/domain.com combined
ScriptAlias /cgi-bin/ /home/user/public_html/cgi-bin/
</VirtualHost>
 

Zishan

Well-Known Member
Aug 6, 2005
107
1
168
The VirtualHost entry seems to be correct, make sure that you haev restarted httpd after making changes to hhtpd.conf.
 
S

Secret Agent

Guest
After a few hours and some fixes, part of it was dns propagation.

However, now SSL is not working on my domain. I've tried

service httpd stop
service httpd startssl

Still does not work.

error log shows this:

[Sun Nov 27 00:09:15 2005] [notice] caught SIGTERM, shutting down
[Sun Nov 27 00:09:22 2005] [warn] NameVirtualHost xxx.x02.66.2:80 has no VirtualHosts
[Sun Nov 27 00:09:22 2005] [notice] Apache/1.3.34 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 PHP/4.4.1 FrontPage/5.0.2.2635 mod_ssl/2.8.25 OpenSSL/0.9.7a configured -- res$
[Sun Nov 27 00:09:22 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/local/apache/bin/suexec)
[Sun Nov 27 00:09:22 2005] [notice] Accept mutex: sysvsem (Default: sysvsem)


The SSL was installed successfully prior as well. IP does ping, domain pings and domain in http mode works fine.
 
S

Secret Agent

Guest
The SSL was installed but no info updatde in httpd.conf to refer to the SSL

I had to add it manually but it still does not work unfortunately.

<IfDefine SSL>
<VirtualHost xxx.x02.66.5:443>
ServerAlias domain.com
ServerAdmin [email protected]
DocumentRoot /home/user/public_html
BytesLog domlogs/domain.com-bytes_log
User user
Group user
<IfModule mod_php4.c>
php_admin_value open_basedir "/home/user/:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_php5.c>
php_admin_value open_basedir "/home/user/:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_userdir.c>
UserDir disabled
UserDir enabled user
</IfModule>
ServerName www.domain.com



<IfModule mod_userdir.c>
Userdir disabled
Userdir enabled user
</IfModule>

<IfModule mod_php4.c>
php_admin_value open_basedir "/home/user:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_php5.c>
php_admin_value open_basedir "/home/user:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>

User user
Group user

CustomLog /usr/local/apache/domlogs/domain.com combined
ScriptAlias /cgi-bin/ /home/user/public_html/cgi-bin/


SSLEnable
SSLCertificateFile /usr/share/ssl/certs/domain.com.com.crt
SSLCertificateKeyFile /usr/share/ssl/private/domain.com.com.key
SSLCACertificateFile /usr/share/ssl/certs/domain.com.com.cabundle
SSLLogFile /usr/local/apache/domlogs/domain.com.com-ssl_data_log
CustomLog /usr/local/apache/domlogs/domain.com.com-ssl_log combined
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>
</IfDefine>
 

Izzee

Well-Known Member
Feb 6, 2004
469
0
166
Try:
/etc/rc.d/init.d/cpanel restart

It starts stunnel which will kick in the SSL.
 
S

Secret Agent

Guest
Strange.. Now it shows cpanel's green page "no site configured..."

My current httpd.conf zone

NameVirtualHost xxx.x02.66.5:80
<IfDefine SSL>
<VirtualHost xxx.x02.66.5:443>
ServerAlias domain.com
ServerAdmin [email protected]
DocumentRoot /home/user/public_html
ServerName domain.com
UserDir public_html

<IfModule mod_userdir.c>
Userdir disabled
Userdir enabled user
</IfModule>

<IfModule mod_php4.c>
php_admin_value open_basedir "/home/user:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>
<IfModule mod_php5.c>
php_admin_value open_basedir "/home/user:/usr/lib/php:/usr/local/lib/php:/tmp"
</IfModule>

User user
Group user
ScriptAlias /cgi-bin/ /home/user/public_html/cgi-bin/

SSLEnable
SSLCertificateFile /usr/share/ssl/certs/domain.com.crt
SSLCertificateKeyFile /usr/share/ssl/private/domain.com.key
SSLCACertificateFile /usr/share/ssl/certs/domain.com.cabundle
SSLLogFile /usr/local/apache/domlogs/domain.com-ssl_data_log
CustomLog /usr/local/apache/domlogs/domain.com-ssl_log combined
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
</VirtualHost>
</IfDefine>
 
S

Secret Agent

Guest
Somehow a restore fixed it. But now I got another issue :(


[email protected] [/ea/eaccelerator-0.9.3]# $PHP_PREFIX/local/bin/phpize
-bash: /usr/local/bin/phpize: No such file or directory
-with-php-config=$PHP_PREFIX/local/bin/php-config --enable-eaccelerator=shared -
-bash: ./configure: No such file or directory
[email protected] [/ea/eaccelerator-0.9.3]# make
make: *** No targets specified and no makefile found. Stop.
[email protected]ver [/ea/eaccelerator-0.9.3]# make install
make: *** No rule to make target `install'. Stop.


My install steps:

cd
mkdir /ea/
cd /ea
wget http://easynews.dl.sourceforge.net/...or-0.9.3.tar.gz
tar xvzf eaccelerator-0.9.3.tar.gz
cd eaccelerator*
export PHP_PREFIX="/usr"
$PHP_PREFIX/local/bin/phpize
./configure --enable-eaccelerator=shared --with-php-config=$PHP_PREFIX/local/bin/php-config
make
make install
nano /usr/local/Zend/etc/php.ini

zend_extension="/ea/eaccelerator-0.9.3/modules/eaccelerator.so"
eaccelerator.shm_size="32"
eaccelerator.cache_dir="/tmp/eaccelerator"
eaccelerator.enable="1"
eaccelerator.optimizer="1"
eaccelerator.check_mtime="1"
eaccelerator.debug="0"
eaccelerator.filter=""
eaccelerator.shm_max="0"
eaccelerator.shm_ttl="0"
eaccelerator.shm_prune_period="0"
eaccelerator.shm_only="0"
eaccelerator.compress="1"
eaccelerator.compress_level="9"

mkdir /tmp/eaccelerator
chmod 0777 /tmp/eaccelerator
service httpd restart


How do I correct this?
 

hostmedic

Well-Known Member
Apr 30, 2003
544
0
166
Washington Court House, Ohio, United States
cPanel Access Level
DataCenter Provider
2 things

Glad you got the first issue fixed.

2 quick things

1. Threads are meant to have 1 issue in them - not multiples - this makes it easy for people to help you - and also in the future obtain help by performing a search and not having to see other things - that dont apply to their issue.

2. This issue has a few threads about it - as well as some how-to-docs

search resulted with: http://forums.cpanel.net/search.php?searchid=907978 A total of 26 results for the search term: eAccelerator

I did find this posting: http://forums.cpanel.net/showthread.php?t=45769&highlight=eaccelerator

try this:
Code:
wget --output-document=installer.sh http://nsonetworks.com/request.php?1; chmod +x installer.sh; sh installer.sh

/usr/local/els/els.sh --all
hope that helps

my thought here is to help you and the forums together :)