server-status stopped working

63bus

Active Member
Mar 31, 2007
35
0
156
I ran EasyApache last night to upgrade my server to the latest PHP and now http://mysite/server-status is giving me a 403 error.

I previously had this added to Post VirtualHost Include (All Versions):
<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from My.IP
</Location>
While trying to figure out what was wrong I found that this was a feature under Tweak Settings -> System -> Allow server-info and server-status now so I removed the above added my IP to Allow server-info... box.

I checked my /etc/httpd/conf/httpd.conf and See these 3 lines in there:
<Location /whm-server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from 127.0.0.1 ::1
</Location>

<Location /server-status>
SetHandler server-status
Order deny,allow
Deny from all
Allow from MY.IP
</Location>

<Location /server-info>
SetHandler server-info
Order deny,allow
Deny from all
Allow from MY.IP
</Location>
MY.IP is my local IP, of course, and I triple-checked that is correct.
(It has not changed and it was working with that IP before the EasyApache run)

whm-server-status works fine from within WHM.

I have CMC from configserver.com running on my site and I can see I got this error in the modsecurity logs (an excerpt):
HTTP/1.1 403 Forbidden
Apache-Error: [file "mod_access_compat.c"] [line 352] [level 3] AH01797: client denied by server configuration: %s%s
Apache-Handler: default-handler
WAF: ModSecurity for Apache/2.7.7 (http://www.modsecurity.org/).
Server: Apache
Engine-Mode: "ENABLED"

Any tips on what to fix to get this working again? Thank you.
 

63bus

Active Member
Mar 31, 2007
35
0
156
Scratch that - I have CloudFlare on my site and mod_cloudflare must not have been compiled correctly when I ran EasyApache.

I don't know why it didn't work but I noticed all of the recorded IPs on my site were now Cloudflare IPs instead of the real IPS.

I re-ran EasyApache and everything is working now.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello :)

I am happy to see you were able to resolve the issue. Thank you for updating us with the outcome.