The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server stopped responding

Discussion in 'General Discussion' started by ashd, Aug 17, 2005.

  1. ashd

    ashd Member

    Joined:
    Feb 19, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I had my server formatted today, and it now runs Fedora Core 2 with cPanel, however whilst running the initial WHM first time setup, i got to the stage where it loads up /scripts/sixthcommand and upon it trying to run that, the server stopped responding to all but pings,
    Does anyone have any suggestions on why this is happening and how to fix it?
     
  2. elix

    elix Well-Known Member

    Joined:
    Jan 18, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    Are you able to get on the command line (SSH)?

    Regards,
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That sometimes can happen when quotaing is enabled for the first time. A reboot and logging back into WHM usually sorts it out. If not, you should probably either look to support from your server provider or cPanel. If you have the opportunuity, you might want to choose a different OS. FC2 has been EOL for some time now and isn't a great choice.
     
  4. ashd

    ashd Member

    Joined:
    Feb 19, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, A reboot did the trick,
    However now i am having the rndc connection refused error, even after following numerous guides on fixing it,
    Currently my named.conf looks like this:
    Code:
    key "rndckey" {
    	algorithm hmac-md5;
    	secret "RSpqR7mHZnaiBgnn9VPoXw==";
    };
    
    
    controls {
        inet 127.0.0.1 allow { localhost; } keys { "rndckey"; };
    };
    
    
    
    
    zone "." {
            type hint;
            file "/var/named/named.ca";
    };
    my rndc.conf looks like this:
    Code:
    # Start of rndc.conf
    key "rndckey" {
    	algorithm hmac-md5;
    	secret "RSpqR7mHZnaiBgnn9VPoXw==";
    };
    
    options {
    	default-key "rndckey";
    	default-server 127.0.0.1;
    	default-port 953;
    };
    # End of rndc.conf
    
    When i restart named in WHM the output it this:
    Code:
    named started ok Aug 18 19:57:19 server named[2767]: shutting down Aug 18 19:57:19 server named[2767]: no longer listening on 127.0.0.1#53 Aug 18 19:57:19 server named[2767]: no longer listening on 207.226.21.171#53 Aug 18 19:57:19 server named[2767]: exiting Aug 18 12:57:19 server named: named shutdown succeeded Aug 18 19:57:19 server named[2861]: starting BIND 9.2.3 -u named -t /var/named/chroot Aug 18 19:57:19 server named[2861]: using 1 CPU Aug 18 19:57:19 server named[2861]: loading configuration from '/etc/named.conf' Aug 18 19:57:19 server named[2861]: listening on IPv4 interface lo, 127.0.0.1#53 Aug 18 19:57:19 server named[2861]: listening on IPv4 interface eth0, 207.226.21.171#53 Aug 18 19:57:19 server named[2861]: couldn't add command channel 127.0.0.1#953: not found Aug 18 19:57:19 server named[2861]: couldn't add command channel ::1#953: not found Aug 18 19:57:19 server named[2861]: running Aug 18 12:57:19 server named: named startup succeeded
     
  5. elix

    elix Well-Known Member

    Joined:
    Jan 18, 2005
    Messages:
    67
    Likes Received:
    0
    Trophy Points:
    6
    /scripts/fixndc

    This usually fixes it but, if it does not

    1. Login to your server as root via SSH
    2. Run: pico /etc/rndc.conf
    replace all instances of "rndc-key" with "rndckey"
    3. Run: pico /etc/named.conf
    replace all instances of "rndc-key" with "rndckey"
    4. Run: /scripts/fixnamed
    5. Run: /scripts/fixndc
    6. If you received an error in the last step, run /scripts/fixndc another
    time.
    7. service named restart

    Regards,
     
Loading...

Share This Page