The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server transfer queries

Discussion in 'General Discussion' started by Kailash1, Mar 15, 2009.

  1. Kailash1

    Kailash1 Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    252
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi,

    I have a server which has PHP 4.4.9, MySQL 4.1 and Apache 1.3. Now, I have a new server which has PHP 5.2.9/PHP 4.4.9 (both support), MySQL 5 and Apache 2.2. Do you think it may create any problem if I transfer the account to a new server.

    Specially I want to know will it upgrade MySQL database automatically to MySQL 5 compatible?

    Kailash
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    When we transfer databases, we are doing a SQL dump then a SQL import. This allows for easy transfers among servers with different versions of MySQL. If you have an account that uses some MySQL 5-specific features and then migrate that to a MySQL 4.1 server, that could cause issues.
     
  3. Kailash1

    Kailash1 Well-Known Member

    Joined:
    Nov 27, 2006
    Messages:
    252
    Likes Received:
    2
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    Thanks David,

    So migration from MySQL 4.1 server to MySQL 5 is not a problem right?

    Kailash
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    It shouldn't be problematic. Moving accounts from servers running MySQL 4.1 to 5.0 has become a relatively common thing to do.

    If you do encounter any issues, please let our technical analysts assist you: http://tickets.cPanel.net/submit
     
Loading...

Share This Page