Server's system package manager YUM failed

elpaulli

Member
Jan 17, 2017
6
0
1
United States
cPanel Access Level
Website Owner
I saw similar threads, but was not sure how exactly to applied it to my current server. I am new to server admin, and learning on the fly. So I apologize in advance if I have ask things a few times.
I was trying to update my server through Easy Apache 3, have a CENTOS 6.7 x86 server. And got the following error message.

!! The server's system package manager, 'YUM', failed. !!

!! direct ensure() call will be used (does not support get_command_arrayref_only): pkglist = 'libtool-ltdl-devel libstdc++.x86_64 xorg-x11-devel automake19 expat-dev libXpm-devel krb5-devel readline-dev gmake libidn coreutils libopenssl0.9.7-devel expat-devel libXpm-dev libltdl-devel e2fsprogs-devel ssl-dev libX11-devel flex pam-devel readline-devel bison libopenssl0-dev libXpm lex libjpeg-dev libjpeg-devel ca_root_nss glibc-dev make gd libtool pam-dev autoconf261 libltdl3-devel libpng-devel gcc-c++ fileutils glibc-devel xorg-x11-dev patch cpp libstdc++-dev.x86_64 gettext libpng-dev sed zlib1-devel libstdc++-devel.x86_64 libz-devel openssl-dev libssl-dev autoconf automake libltdl zlib-devel krb5-dev libopenssl0.9.7-static-devel lsof libopenssl0-devel expat openssl libtool-libltdl-devel gcc libidn-devel openssl-devel libtool-ltdl zlib libstdc++-devel.x64_64 libopenssl0' !!

!! Please visit EasyApache FAQ - EasyApache - cPanel Documentation for help with this error. !!

I didn't see much to help me with the link provide.
 

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter
Hello,

This error indicates that the yum update system experienced an error. Yum failed due to multilib problems with the libstdc++ package.

Try to run the following command through SSH.

Code:
yum update
 

elpaulli

Member
Jan 17, 2017
6
0
1
United States
cPanel Access Level
Website Owner
This might be a server issue, but I am logged into the control panel, with the root login, but when I try access the ssh with [email protected] - and use the same password, it does not work? Should I talked to my hosting provider? And I have tried to use the change root password, and that did not effect it. Any suggestions?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello,

You may want to try running a temporary instance of SSH to see if it allows you to access your server to investigate:

Code:
https://IP:2087/cpsess12345678/scripts2/doautofixer?autofix=safesshrestart
You would replace "IP" with the server's IP address and the session number with what's displayed in your address bar after accessing WHM as root. Note that this is simply a temporary instance of SSH so you can login and determine what's wrong with the standard SSH service. Once logged in, use the following guide to update your SSH configuration:

SSH Hardening Guide

Thank you.