The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Service Manager and Mailserver Configuration

Discussion in 'E-mail Discussions' started by thobarn, Feb 24, 2009.

  1. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    What is the relation between

    Main >> Service Configuration >> Service Manager >> Courier IMAP and Courier POP3 server check boxes

    and

    Main >> Service Configuration >> Mailserver Configuration >> Courier configuration >> Protocols enabled (POP3, IMAP) check boxes?

    I would like to use POP3 but not IMAP. Disabling (unchecked) only IMAP in the former disables the Mailserver Configuration interface in latter completely and sets the Main >> Service Configuration >> Mailserver Selection to disabled.

    So although IMAPD and IMAPDSSL are disabled (unchecked) under Main >> Service Configuration >> Mailserver Configuration, one has to leave both Courier IMAP and Courier POP3 boxes checked under Main >> Service Configuration >> Service Manager.


    cPanel 11.24.4-R33609 - WHM 11.24.2 - X 3.9
    CENTOS 4.7 x86_64 on virtuozzo

    and

    cPanel 11.24.4-C34253 - WHM 11.24.2 - X 3.9
    CENTOS 5.2 i686 on virtuozzo
     
  2. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    Bump

    Anyone?
     
  3. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi! Did you already tried this?

    Go to: Main >> Service Configuration >> Mailserver Configuration >> Courier Configuration
    Untick IMAPD & IMAPDSSL. Save options.
    This will disallow Courier from listen on IMAP ports.


    Go to: Main >> Service Configuration >> Service Manager
    Untick imap (both Enabled and Monitor options)
    This will unload imap services from memory and keep'em off.
     
  4. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    Thanks for taking time to reply.

    This is how it is set currently.

    I thought that would be the next step but as soon as I do that Main >> Service Configuration >> Mailserver Configuration >> Courier Configuration (hence the POP3 related options) become disabled ("The Mail server is currently disabled. Use the Mailserver Selection interface to enable it.") So one has to leave the IMAP ticked under Service manager :confused:

    Thanks again for your time and help
     
    #4 thobarn, Mar 18, 2009
    Last edited: Mar 18, 2009
  5. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    anybody? is there a way to untick Main >> Service Configuration >> Service Manager >> IMAP without disabling Main >> Service Configuration >> Mailserver Configuration >> Courier Configuration?
     
  6. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    bump

    anyone, please? How can I stop IMAP in service manager without completely disabling Courier configuration UI?
     
  7. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hi! I've tested the facts you commented and effectively I experimented the same situations. It seems to be some kind of bug in WHM that doesn't allow to disable correctly the IMAP services. Luckily, if you go to: Main >> Service Configuration >> Mailserver Configuration >> Courier Configuration and untick only the IMAPD & IMAPDSSL options and save, the IMAP will not be available to the users, yet the daemon will be still loaded. I think this is due to the fact that the same daemon (being Courier or Dovecot) serves both POP and IMAP services.
    Another un-useful way to get what you want, if you use CSF is to close the IMAP ports 443 and 995.
    May somebody at the staff add some more illumination to this issue.

    Best Regards
     
    #7 Kent Brockman, Mar 29, 2009
    Last edited: Mar 30, 2009
  8. thobarn

    thobarn Well-Known Member

    Joined:
    Apr 25, 2008
    Messages:
    153
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    sanctum sanctorum
    Many thanks for sparing time to test this. At least I now know it is not something I am doing wrong. I filed a bug for this now. Thanks again for your time.
     
  9. Kent Brockman

    Kent Brockman Well-Known Member

    Joined:
    Jan 20, 2008
    Messages:
    1,130
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Buenos Aires, Argentina
    cPanel Access Level:
    Root Administrator
    Twitter:
    It's pretty strange. I'd never disabled imap so I never noticed this. Let's hope they can fix it. Regards
     
Loading...

Share This Page