The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Service Manager - Run Exim on another port - changed.

Discussion in 'E-mail Discussions' started by 4u123, Aug 18, 2016.

  1. 4u123

    4u123 Well-Known Member
    PartnerNOC

    Joined:
    Jan 2, 2006
    Messages:
    765
    Likes Received:
    1
    Trophy Points:
    18
    I just noticed while configuring new servers since WHM version 58, the option in Service Manager to run Exim from additional ports no longer adds those ports to the Exim configuration for you.

    By default this has port 26 listed. If you enable the service - it does nothing other than monitor it. The Exim config isn't updated to include port 26 - subsequently, service failure messages start hitting your inbox. So you should now consider this option more as "Which ports do you want to monitor" rather than "which additional ports do you want to run Exim from".

    To add additional ports you need to go into Exim Configuration Manager > Advanced and add the required ports into the daemon_smtp_ports section.

    I wanted to leave this note here for anyone else who may have this problem but who might not be aware of the daemon_smtp_ports configuration option.

    ..............................

    Unable to connect to port 26 on 127.0.0.1: Connection refused: Died
    The service “exim-26” appears to be down
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Internal case CPANEL-7590 addresses an issue where /etc/exim.conf.local is automatically created with the following entry after saving a change in "WHM >> Service Manager >> Exim Configuration Manager >> Advanced Editor":

    Code:
    daemon_smtp_ports = 25 : 465 : 587
    This results in an inability for "WHM >> Service Manager" to properly add the new port when "Exim Mail Server (on another port)" is enabled. The resolution is included with cPanel version 60:

    Fixed case CPANEL-7590: Fix handling exim ports from exim.conf.local.

    In the meantime, the current workaround is to manually add the new port to the daemon_smtp_ports line in /etc/exim.conf.local (ensuring to run "/usr/local/cpanel/scripts/buildeximconf" after making the change) or via "WHM >> Service Manager >> Exim Configuration Manager >> Advanced Editor".

    Thank you.
     
Loading...

Share This Page