The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Services (ccpop, ssh, perl) keep dieing

Discussion in 'General Discussion' started by Woogs, Aug 7, 2003.

  1. Woogs

    Woogs Member

    Joined:
    Jul 22, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    After about 6 days of uptime my processes keep dieing. ccpop stops accepting connections, ssh refuses connections and perl does not run within Apache.

    The only solution I have is to reboot the server and then it is fine again for a few days. I can't connect into WHM either so I need to hard reboot my server using my APC Remote Reboot switch.

    Any suggestions on what is causing this?

    I noticed this when I first setup the server (July 24th) and then it went away and today it has come back.

    Thanks
    Ryan

    cPanel.net Support Ticket Number:
     
  2. Woogs

    Woogs Member

    Joined:
    Jul 22, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    I forgot to mention this is with RH 9 and the latest stable build of cPanel.

    cPanel.net Support Ticket Number:
     
  3. mjm

    mjm BANNED

    Joined:
    Aug 1, 2003
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6
    have you checked your log files?

    cPanel.net Support Ticket Number:
     
  4. Woogs

    Woogs Member

    Joined:
    Jul 22, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Yep I checked them but there were no logs.

    Aug 7 07:55:31 phoenix pure-ftpd[18471]: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Aug 7 07:55:31 phoenix pure-ftpd[18471]: (?@127.0.0.1) [INFO] Logout - CPU time spent: 0.000 seconds.
    Aug 7 07:58:54 phoenix named[19401]: lame server resolving 'web.webcoach.com' (in 'webcoach.com'?): 63.225.95.58#53
    Aug 7 08:03:52 phoenix pure-ftpd[18635]: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
    Aug 7 08:03:52 phoenix pure-ftpd[18635]: (?@127.0.0.1) [INFO] Logout - CPU time spent: 0.010 seconds.
    Aug 7 10:42:54 phoenix syslogd 1.4.1: restart.
    Aug 7 10:42:54 phoenix syslog: syslogd startup succeeded

    Goes from the last state before everything died and then comes back after I restarted the server.

    cPanel.net Support Ticket Number:
     
  5. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    I have been having this same problem!!! Services just die for no apparent reason. Error logs show nothing! I have had Cpanel look thru my logs and they didn't find anything either. Only option is to reboot the server.

    It's happening to me on a daily basis. About ready to pull my hair out. I have RH 7.3, and CP 7.4.2 S-82.

    Acutally on one of our servers the guy at Cpanel found that my domlogs folder had really filled up with tons of stuff. He renamed the folder to domlogs2 and that server has actually not crashed again yet.

    But other one is crashing and it's definatly not a log problem, it's a new server.

    cPanel.net Support Ticket Number:
     
  6. nitromax

    nitromax Well-Known Member

    Joined:
    Feb 12, 2002
    Messages:
    189
    Likes Received:
    0
    Trophy Points:
    16
    I had 2 problems. The first was that I had faulty RAM on my server. RackShack replaced it but it still crashed.

    Then as I ran the dmesg command at the SSH prompt I noticed some DMA errors. Please read the following post:

    http://forums.cpanel.net/showthread.php?s=&threadid=13915&highlight=DMA


    Not sure if it will help you, but couldn't hurt to check if you are still having the problem.

    cPanel.net Support Ticket Number:
     
  7. Woogs

    Woogs Member

    Joined:
    Jul 22, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Thanks I will give this a try.

    Ryan

    cPanel.net Support Ticket Number:
     
  8. Woogs

    Woogs Member

    Joined:
    Jul 22, 2003
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Well I turned of DMA and changed the IDE cable and thought this fixed it as my server did not die after 6-7 days. But today at 18.5 days it happened, perl, ssh, ccpop, etc was all dead. I saw errors of cant write to /tmp which makes no sense as there is plenty of space free on the drive.

    Once again rebooting fixes this problem. After reboot I see lots of unrefereces inodes deleted via dmesg, so I reboot again (2nd time) and then it is all clean.

    Any suggestions? I am getting very irritated with this continous problem. The hard drive is a brand new 160 GB WD 8MB cache.

    Ryan

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page