The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Services not restarting after reboot

Discussion in 'General Discussion' started by jammin, Sep 6, 2004.

  1. jammin

    jammin Member

    Joined:
    Sep 6, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Hi All,

    I've just started using WHM and only installed it on my debian server a few days ago. It appeared to install fine but now when I reboot some of the vital services are not running.

    I've compared the ps list from after the installation to the ps list from after a rebbot so I could try to restart the services manually but it still doesn't work until I re-install.

    Any advice?

    Thanks

    Ben Wrigley
     
  2. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    From the prompt you can try chkconfig --list. This should give you a list of what is currently running at boot. Running chkconfig --help will give you the syntax to add services for different run levels.
     
  3. jammin

    jammin Member

    Joined:
    Sep 6, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    all sorted...

    Thanks for that.

    What I ended up doing was installing rcconf and running that and just selecting cpanl and httpd as services to start at start up.

    Nice utility!

    Ben
     
Loading...

Share This Page