The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Session Cookies

Discussion in 'Security' started by brittbratt, Apr 9, 2015.

  1. brittbratt

    brittbratt Member

    Joined:
    Jan 22, 2015
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Boston
    cPanel Access Level:
    Root Administrator
    Hey my whm is set cookies IP to strict default at the moment I don't have a regular WiFi connection on my hot spot when I try to login to cpanel I get a broken screen and I can't set the cookies to disabled so I can't view anything and update it how do I fix this
     
  2. danrussell

    danrussell Well-Known Member

    Joined:
    Nov 5, 2014
    Messages:
    60
    Likes Received:
    3
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi :),

    In that case, just set the Cookie settings to Loose, that will fix your issue.
     
  3. quizknows

    quizknows Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    940
    Likes Received:
    55
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    I believe OP is saying she cannot access that setting to change it, due to the current setting.

    If you have SSH access, you can set the proper setting in the file /var/cpanel/cpanel.config

    In that file there is the setting for "cookieipvalidation=strict"

    You should be able to change that to "loose" or "disabled" and save the file. Then run /usr/local/cpanel/scripts/restartsrv_cpsrvd to restart cPanel/WHM to apply the changes.

    That being said, you should be able to just do a fresh login (clear your browser cache, or use "private browsing") to get a new cookie for your current IP instead. If that doesn't work, the above advice should allow you to change the setting.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,724
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. brittbratt

    brittbratt Member

    Joined:
    Jan 22, 2015
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Boston
    cPanel Access Level:
    Root Administrator
    I contacted cpanel and was able to get it resolved sorry I wasn't watching this topic so I got no notification
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,724
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    I am happy to see the issue was resolved. To clarify, was the solution any different to the post from quizknows?

    Thank you.
     
  7. brittbratt

    brittbratt Member

    Joined:
    Jan 22, 2015
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Boston
    cPanel Access Level:
    Root Administrator
    I'm not sure all they did was login to whm and fix the error I'm not sure if they ssh or of they used the direct whm panel
     
Loading...

Share This Page