The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Set http://www.mysite.com instead of http://mysite.com

Discussion in 'General Discussion' started by mattyfog, Jan 28, 2012.

  1. mattyfog

    mattyfog Member

    Joined:
    Jan 28, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    As the title I'd like to know how I can set http://www.mysite.com instead of http://mysite.com as default. In fact now if I go to http://www.mysite.com I will be redirected to http://mysite.com . I'd like to set the url with the "www" as default. How I can do it?
    Thank you a lot :)
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can access the "Redirects" option within cPanel to redirect the non-www URL to the URL that includes the "www" prefix.

    Please let us know if you have any trouble making this change.

    Thank you.
     
  3. mattyfog

    mattyfog Member

    Joined:
    Jan 28, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    But will it work for every page of my site? Will it be permanent?
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you select "Do Not Redirect www." and "Wild Card Redirect" and then enter into the "redirects to→" field http://www.domain.com without the trailing / on it, you should have it redirect all requests to www.domain.com from domain.com url.

    I've attached a screen print of how it would look to set this up properly.

    Screen shot 2012-01-31 at 1.45.40 AM.png
     
  5. mattyfog

    mattyfog Member

    Joined:
    Jan 28, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Oh my god, this support is brilliant! I didn't expect a good answer like this :D The image was fantastic for me because my English is a bit bad :D
    Thank you very much!
     
  6. mattyfog

    mattyfog Member

    Joined:
    Jan 28, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Ok, the problem hasn't been solved yet
    Now when I go to my home page the home page isn't loaded as you can see both /http://www.disgustingapps.com/ and /http://disgustingapps.com/ aren't loaded. But I installed wordpress with "fantastico" from cpanel. Before I create the redirect it worked... Can you help me? Thanks
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You've setup your redirect incorrectly it seems. I suggest you remove that redirect and then edit your wordpress config area where you add your domainname and add the www. there instead.

    Wordpress admin > Settings > General > WordPress Address (URL) change, yourdomain.com to, www.yourdomain.com and save. When you do you'll be logged out of admin. Log back in. You should be good to go.
     
  8. mattyfog

    mattyfog Member

    Joined:
    Jan 28, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    So the problem is solved without cpanel, i'm sorry for wrong the forum!
    Thank you very very very much :)
     
  9. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,482
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You're certainly welcome. Good luck with your new site! :)
     
  10. hocquantrimang

    Joined:
    Feb 13, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    i think you should use CNAME in DNS settings
     
Loading...

Share This Page