borayeris

Member
Jan 28, 2015
18
4
3
cPanel Access Level
Root Administrator
Hi,

I always set mail.log in php.ini. It was working fine untill 22 June.

/usr/local/lib/php.ini
mail.add_x_header = 1
mail.log = /var/log/maillog

File right 666
Owner nobody:nobody
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,749
2,205
363
cPanel Access Level
DataCenter Provider
Twitter
Hello :)

The MailHeader patch is installed by default as part of the core PHP installation in EasyApache 4:

Rich (BB code):
$ /opt/cpanel/ea-php72/root/usr/bin/php -i|grep mail.add_x_header
mail.add_x_header => On => On
To update the "mail.log" PHP configuration setting, you must browse to MultiPHP INI Editor, select each version of PHP enabled on your server, click on "Editor Mode", and modify the following section to your preferences:

Code:
; The path to a log file that will log all mail() calls. Log entries include
; the full path of the script, line number, To address and headers.
;mail.log =
; Log mail to syslog;
;mail.log = syslog
Please revert any previous actions you took to modify the php.ini file and it's permissions/ownership values in the past, and instead use MultiPHP INI Editor.

Thank you.