Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Set SFTP destination to use IPv4 only?

Discussion in 'Data Protection' started by msullivan, Feb 19, 2018.

Tags:
  1. msullivan

    msullivan Member

    Joined:
    Jan 25, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    Sometime in the past two weeks, something changed that has forced two of my servers to attempt to connect to my offsite backup system using IPv6 (the server hosting the offsite does not support IPv6). Since then the remote backup destination has failed with a connection timeout and I've had to manually transfer the files.

    I can verify the offsite server is reachable from the servers by manually connecting via the command line. Using just the SFTP command it tries and eventually fails to connect via IPv6, then attempts to connect on IPv4, and does so without any delay.

    I thought I might be able to workaround the issue by extending the timeout on the remote destination but that didn't work, no matter what value I set.

    If I manually attempt to connect using the -4 flag on the SFTP command, I'm connected without any delay.

    Is there anyway to force the backup system to use IPv4 for SFTP remote destinations?

    Thanks,
    Michael
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,215
    Likes Received:
    1,759
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello Michael,

    When configuring the SFTP backup destination, can you try entering the specific IPv4 address as the host instead of the hostname to see if that helps?

    Thank you.
     
  3. msullivan

    msullivan Member

    Joined:
    Jan 25, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Such a simple solution, didn’t even consider it! This appears to work. Thanks!

    Michael
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,215
    Likes Received:
    1,759
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
Loading...

Share This Page