The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Set Up Sending Mail through Mail Relay Server

Discussion in 'E-mail Discussions' started by CraftyPanda, Aug 24, 2014.

  1. CraftyPanda

    CraftyPanda Well-Known Member

    Joined:
    Nov 15, 2012
    Messages:
    84
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi all,

    I am trying to figure out how to set up my WHM server to send mail out through MailJet.

    I can't see instructions on how to input the username and password in WHM that was given to me by mailjet for authentication.

    Any help would be very much appreciated.

    Andy
     
  2. CraftyPanda

    CraftyPanda Well-Known Member

    Joined:
    Nov 15, 2012
    Messages:
    84
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi Micheal,

    Thank you for this. I followed the instructions and mail started going out through Mail Jet. However the following started happening too...

    Inbound mail to accounts on the whm server were being accepted(delivery reports confirmed) but not arriving in individual mailboxes. But they were showing up in Mailjets dashboard as sent emails?? As if they were arriving at the server as they should but then been sent straight out again through mailjet.

    Does that make sense? Obv Ive done something wrong!

    Andy
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  4. CraftyPanda

    CraftyPanda Well-Known Member

    Joined:
    Nov 15, 2012
    Messages:
    84
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hi Micheal,

    Here is one entry for an inbound email.

    Code:
    09:13:08 SMTP connection from [62.27.66.184]:47233 (TCP/IP connection count = 1)
    2014-08-26 09:13:11 1XMBsK-0007NN-Pg H=mail.celes-systems.net [62.27.66.184]:47233 Warning: "SpamAssassin as ghbnvfe3 detected message as NOT spam (0.0)"
    2014-08-26 09:13:11 1XMBsK-0007NN-Pg <= [email]madeupemail@madeupemail.com[/email] H=mail.celes-systems.net [62.27.66.184]:47233 P=esmtps X=TLSv1:DHE-RSA-AES256-SHA:256 S=58476 id=10D88ED1BB209141B7BA5B024131F111793A944F@EXMBX03.celes-systems.net T="RE:  a step forward" for [email]madeupemail@madeupemail.com[/email]
    2014-08-26 09:13:11 SMTP connection from mail.celes-systems.net [62.27.66.184]:47233 closed by QUIT
    2014-08-26 09:13:11 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1XMBsK-0007NN-Pg
    2014-08-26 09:13:11 1XMBsK-0007NN-Pg => [email]madeupemail@madeupemail.com[/email] R=remoteserver_route T=remoteserver_relay H=in-v3.mailjet.com [5.135.135.65] X=UNKNOWN:ECDHE-RSA-AES256-GCM-SHA384:256 A=remoteserver_login C="250 2.0.0 Ok: queued as 1A72A96025D"
    2014-08-26 09:13:11 1XMBsK-0007NN-Pg Completed
    
    Is that saying its being sent straight out again?

    Andy
     
    #5 CraftyPanda, Aug 26, 2014
    Last edited by a moderator: Aug 26, 2014
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  6. CraftyPanda

    CraftyPanda Well-Known Member

    Joined:
    Nov 15, 2012
    Messages:
    84
    Likes Received:
    1
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Morning Michael,

    This behaviour is the same for any incoming email for the time the server was configured this way. I only left the configuration like this for a day max due to realising the issues though, so I cant tell you that this is happening for gmail etc for certain.

    Andy
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,811
    Likes Received:
    671
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You may want to try temporarily enabling the custom workaround again to see if you can reproduce the issue with the conditions referenced in my previous post. Note that custom workarounds are not officially supported, so you may also want to consult with a qualified system administrator for assistance.

    Thank you.
     
Loading...

Share This Page