The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

setfiles processs on update

Discussion in 'General Discussion' started by consultorpc, Apr 13, 2006.

  1. consultorpc

    consultorpc Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    When we do a manual update we see a process "setfiles" consuming a lot of CPU power for 30 min. Is there any way to avoid this ?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I don't know why they have to run it every time, but it is a pain. If it has already run through once already I usually just kill off that one process. I haven't checked /scripts/upcp through for the conditions that force this to run, but you might want to ensure that /etc/selinux/config is set to disabled and not permissive or anything else (if you change it, reboot).
     
  3. mOdY

    mOdY Well-Known Member

    Joined:
    Dec 25, 2004
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    you mean that selinux must be turned off in general for cpanel or just before upcp ?
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    SELinux should always be set to disabled on a cPanel server.
     
  5. consultorpc

    consultorpc Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2003
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    I do have SELINUX=disabled in config file, but the "setfiles" command still runs.
     
  6. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    setfiles is forced to run by /scripts/mysqlup

    So - do you think we should remove it from mysqlup?
     
  7. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    And what do you think about removing it from /scripts/mysqlup ???
     
  8. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    This is old thread, I know, but please help me with /usr/sbin/setfiles from /scripts/mysqlup - it is running on 2 my servers, causing high iowait and load problems.

    Any idea how to stop it? I have SElinux disabled on all my CentOs 4.3. servers.

    Tom
     
  9. Paxuist

    Paxuist Member

    Joined:
    Jul 11, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here ...
     
  10. Nic

    Nic Member

    Joined:
    Dec 9, 2003
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    I simply kill setfiles process by kill -9
     
  11. alwaysweb

    alwaysweb Well-Known Member

    Joined:
    Mar 8, 2002
    Messages:
    97
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Dallas, TX
    cPanel Access Level:
    Root Administrator
    See [thread=40843]thread 40843[/thread] for an easy fix via disabling 'setfiles.' We had to do this because it was causing issues and STILL running even though selinux is disabled in /etc/selinux/config
     
  12. web12

    web12 Well-Known Member

    Joined:
    Nov 20, 2002
    Messages:
    240
    Likes Received:
    0
    Trophy Points:
    16
    Did you find it was ok after disabling SELINUX and moving the file for it?

    Thanks
     

Share This Page