Setting SPF uses private IP instead of public

carolainn

Active Member
Feb 22, 2018
32
11
8
Argentina
cPanel Access Level
Root Administrator
Hello there!

When I enable the SPF the value uses the private IP of the server, instead of the public one. Why is this? and how can I change it so it doesn't happens again?

I've noticed that me and my clients are having some email issues, like not receiving some emails with no notification from the server, or people that uses outlook, and it is not able to connect properly, despite the user, password, ports, etc are correct.

Any thought?
Thanks!
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,293
1,280
313
Houston
Hi @carolainn

I had opened a case about mail deliverability reports reporting the internal IP address erroneously and it was found that this seems to only occur in cases where the NAT configuration is not set up properly. Can you tell me what the output of the following is:

Code:
cat /var/cpanel/cpnat
 

carolainn

Active Member
Feb 22, 2018
32
11
8
Argentina
cPanel Access Level
Root Administrator
Lauren,

Here's the output.

warn [build_cpnat] Unable to map xx.xxx.x.176
info [build_cpnat] xxx.xx.xx.234 => xxx.xx.xx.234
info [build_cpnat] All publicly routeable addresses are the same as the local address. Not a NAT system.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,293
1,280
313
Houston
In your initial message you indicated:

When I enable the SPF the value uses the private IP of the server, instead of the public one
But based on the output of that command you do not have a private IP address.
 
  • Like
Reactions: carolainn

carolainn

Active Member
Feb 22, 2018
32
11
8
Argentina
cPanel Access Level
Root Administrator
In your initial message you indicated:



But based on the output of that command you do not have a private IP address.
Sorry, my mistake. I meant reserved IP (10.xxx.x.176) which only the server uses.
All the accounts are configured with the other one (148.xx.xx.234), but when I set the SPF on, it uses the reserved IP by default.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,293
1,280
313
Houston
Hi @carolainn
Sorry, my mistake. I meant reserved IP (10.xxx.x.176) which only the server uses.
All the accounts are configured with the other one (148.xx.xx.234), but when I set the SPF on, it uses the reserved IP by default.
10. anything should be a private IP address it sounds as though there may be a misconfiguration with the NAT routing please feel free to open a ticket while we won't be able to resolve issues with the configuration itself we may be able to let you know how to proceed.
Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!