The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Setting up Sub-Addressing

Discussion in 'E-mail Discussions' started by Bernard Lechler, Feb 12, 2016.

  1. Bernard Lechler

    Bernard Lechler Registered

    Joined:
    Feb 12, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London Ontario
    cPanel Access Level:
    Root Administrator
    Hi Everybody!

    I am attempting to set up an email account with sub-addressing. I want to be able to send an email to userx+anything@mydomain.com and have it go to userx@mydomain.com.

    - I went into CPanel and in the email section I went into Global Email Filters.
    - I created a newfilter and named it UserX.
    - Under Rules I chose "To" and "begins with" and in the field I entered "userx+" (without the quotes)
    - under Actions I chose "Redirect to Email" and I entered userx@mydomain.com
    - I clicked Create and I saw a promising message in green that advised me of my success

    I alt-tabbed back to Outlook and confidently sent an email to userx+1@mydomain.com. After a moment I received a message in my inbox:

    Code:
    Your message couldn't be delivered because the recipient's email system reported the following error: '550 Unrouteable address'.
    
    Well, that's not what I was hoping for. During this time I'm also tailing the exim log file and it confirmed with "...rejected RCPT <userx+1@mydomain.com>: No such person at this address."

    "OK" I said to myself, "Perhaps I misunderstood what a global email filter is for." However there was a form there that allows me to test the filter so I entered the following:

    Code:
    To: [EMAIL]userx+1@mydomain.com[/EMAIL]
    From: test@localhost
    Subject: test
    
    This is a test message.
    
    When I hit the Test Filter button I was advised that:

    Code:
    [B][U]The Filter has matched the following condition(s): [/U]
    $header_to: begins userx+[/B]
    Return-path copied from sender
    Sender      = [EMAIL]systemaccount@vps.mydomain.com[/EMAIL]
    Recipient   = [EMAIL]systemaccount@vps.mydomain.com[/EMAIL]
    Testing Exim filter file "/etc/vfilters/mydomain.com"
    
    Deliver message to: [EMAIL]userx@mydomain.com[/EMAIL]
    [B]Filtering set up at least one significant delivery or other action.
    No other deliveries will occur.[/B]
    
    I restarted the mail server and sent the same email again, and got the same result.

    I deleted the global filter and followed the instructions at geek.michaelgrace.org/2015/05/setup-gmail-like-plus-addressing-on-shared-cpanel-hosting/'. I set my system account as the default address, and then went into "Email Filters" I selected "Manage Filters" beside my system account and created the same filter as outlined above. I sent another email, and in my logs I see "...rejected RCPT <userx+1@mydomain.com>: Unrouteable address" and a message in my inbox informing me of essentially the same.

    I deleted that filter and did the same thing, setting up the default address as administrator@mydomain.com and setting up a filter on that account as well. I got the same results. It never seems to run the filter despite the fact that the "Filter Test" assures me that all is well.

    I finally double checked the forwarders I have set up on the account and can confirm that nothing there is interfering with any of the email addresses involved.

    Thanks in advance for your assistance.
     
    #1 Bernard Lechler, Feb 12, 2016
    Last edited by a moderator: Feb 12, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The destination forwarder addresses will accept plus signs. However, plus signs for the source email address are not supported. Here's an open feature request that you can add feedback to, and vote for:

    Email sub-addressing (plus addressing) | cPanel Feature Requests

    Note that a custom workaround is referenced in the comments section of this request.

    Thank you.
     
  3. Bernard Lechler

    Bernard Lechler Registered

    Joined:
    Feb 12, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London Ontario
    cPanel Access Level:
    Root Administrator
    This feature request has been languishing for more than two years with no apparent movement. I tried the referenced "workaround" and it doesn't work. I made modifications directly to exim.conf, but that apparently gets overwritten on a frequent basis. I guess there is no solution forthcoming.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  5. Chip Runner

    Chip Runner Registered

    Joined:
    Feb 24, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    USA
    cPanel Access Level:
    Website Owner
    It is great that you are replying to this thread, and pointing to the feature request -- however it's over 2 years old! Is cPanel listening? Any possible timeline on implementation? Please!
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,852
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    There's no update to report at this time, however I encourage anyone who wants this feature implemented to vote and add feedback to the feature request.

    Thank you.
     
Loading...

Share This Page